Project

General

Profile

Bug #14687

RPM: no /usr/libexec directory on SUSE

Added by Nathan Cutler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/09/2016
Due date:
% Done:

100%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The ceph-osd-prestart.sh script is installed in /usr/libexec/ceph/ and indeed this directory is hard-coded in the file systemd/ceph-osd@.service.

This causes problems on SUSE which does not have a /usr/libexec directory.

Agreed that putting the script in /usr/lib/ceph is the most straightforward fix, since /usr/lib exists everywhere.


Subtasks

Cleanup #14705: Reinstate ceph-osd@.service.inClosedNathan Cutler

Associated revisions

Revision 69291f87 (diff)
Added by Nathan Cutler over 3 years ago

packaging: move ceph_common.sh and ceph-osd-prestart.sh to /usr/lib/ceph

First, it makes sense for both ceph_common.sh and ceph-osd-prestart.sh to
reside in the same directory: make it so.

Second, /usr/lib exists on both RHEL/Fedora and SLE/openSUSE, whereas
the later lacks /usr/libexec. To make this less painful, package
ceph_common.sh and ceph-osd-prestart.sh in /usr/lib/ceph.

Third, allow e.g. FreeBSD to do its own thing by using the $(libexecdir)
Autoconf variable (but set it to /usr/lib in the spec file).

http://tracker.ceph.com/issues/14687 Fixes: #14687

Signed-off-by: Nathan Cutler <>

History

#1 Updated by Loic Dachary over 3 years ago

  • Status changed from New to Verified
  • Priority changed from Normal to High

#2 Updated by Nathan Cutler over 3 years ago

Discussed on ceph-devel mailing list. Consensus seems to be to use sh -c where possible and, failing that, generate the unit file from an .in template at build time.

#3 Updated by Nathan Cutler over 3 years ago

It seems that the only path that is actually causing trouble now (at least on SUSE) is /usr/libexec.

#4 Updated by Nathan Cutler over 3 years ago

  • Subject changed from Hardcoded paths in systemd unit files to RPM: no /usr/libexec directory on SUSE

Changing issue title to reflect narrower scope.

#5 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)
  • Status changed from Verified to In Progress
  • Release set to jewel

#6 Updated by Nathan Cutler over 3 years ago

  • Status changed from In Progress to Need Review

#7 Updated by Nathan Cutler over 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF