Project

General

Profile

Tasks #11090

firefly v0.80.10

Added by Loic Dachary over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
01/26/2015
Due date:
% Done:

0%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

Workflow

  • Preparing the release
  • Cutting the release
    • Loic asks Sage if a point release should be published YES
    • Loic gets approval from all leads
      • Yehuda, rgw: YES
      • Gregory, CephFS: YES
      • Josh, RBD: YES
      • Sam, rados: YES
    • Sage writes and commits the release notes YES
    • Loic informs Yuri that the branch is ready for testing
    • Yuri runs additional integration tests DONE
    • If Yuri discovers new bugs that need urgent backporting, the release goes back to being prepared, it was not ready after all
    • Yuri/Loic gets approval from all leads of failed tests if needed
      • Gregory, samba: YES
      • Sam, rados: YES
    • Yuri informs Alfredo that the branch is ready for release DONE
    • Alfredo creates the packages and sets the release tag DONE

Release information

git --no-pager log --format='%H %s' --graph tags/v0.80.9..ceph/firefly | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

teuthology run commit:df053b86a89edf8f390400dad8c5e654e14df327 (wip-11622-firefly may 2015)

rgw

From Wip 11622 firefly

./virtualenv/bin/teuthology-suite --priority 1000 --suite rgw --filter-out btrfs,ext4 --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --ceph wip-11622-firefly

teuthology run commit:df053b86a89edf8f390400dad8c5e654e14df327 (integration branch may 2015)

$ git --no-pager log --merges --oneline ceph/firefly..ceph/firefly-backports
2418cdb Merge 4597: objecter: can get stuck in redirect loop if osdmap epoch == last_force_op_resend
0c0e273 Merge 4584: RGW doesn't return 'x-timestamp' in header which is used by 'View Details' of OpenStack
28a84ac Merge 4583: Change variable length array of std::strings (not legal in C++) to std::vector<std::string>
a5d29d7 Merge 4582: ceph_argparse_flag has no regular 3rd parameter
3eb301f Merge 4556: OSD::load_pgs: we need to handle the case where an upgrade from earlier versions which ignored non-existent pgs resurrects a pg with a prehistoric osdmap
c31ead2 Merge 4535: rgw: use correct objv_tracker for bucket instance
8f3e82b Merge 4416: fix PG::all_unfound_are_queried_or_lost for non-existent osds
0f86f89 Merge 4415: cancel_pull: requeue waiters
c19dcd5 Merge 4414: rgw: keystone token cache does not work correctly
53b42b6 Merge 4379: rgw: use correct objv_tracker for bucket instance

rados

Note: rados suite must run on branch wip-11429-firefly because it is required by OSD::load_pgs: we need to handle the case where an upgrade from earlier versions which ignored non-existent pgs resurrects a pg with a prehistoric osdmap

./virtualenv/bin/teuthology-suite --priority 1000 --suite rados --subset 0/7 --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --ceph firefly-backports

fs

./virtualenv/bin/teuthology-suite --priority 1000 --suite fs -k testing --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --ceph firefly-backports

rgw

The four issues below have been fixed by the #11180 firefly backport

./virtualenv/bin/teuthology-suite --priority 1000 --suite rgw --filter-out btrfs,ext4 --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --ceph firefly-backports

rbd

./virtualenv/bin/teuthology-suite --priority 1000 --suite rbd --filter-out btrfs,ext4 --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --ceph firefly-backports

teuthology run commit:b91bbb434e6363a99a632cf3841f70f1f2549f79 (integration branch april 2015)

$ git rev-parse ceph/firefly
12143ff9b25fdd96f8d1a9cecb1329c7f354d414
$ git rev-parse ceph/firefly-backports
b91bbb434e6363a99a632cf3841f70f1f2549f79
$ git log --no-merges --oneline 12143ff9b25fdd96f8d1a9cecb1329c7f354d414..b91bbb434e6363a99a632cf3841f70f1f2549f79
c0cfd6e osd: erasure-code-profile incremental rm before set
3fb97e2 ReplicatedPG: trim backfill intervals based on peer's last_backfill_started
29bc9e5 PG: set/clear CREATING in Primary state entry/exit
b9da6f1 librbd: snap_remove should ignore -ENOENT errors
b250b3c librbd: get_parent_info should protect against invalid parent
69d9339 PGLog: improve PGLog::check() debugging
73cbb6f PGLog::merge_log: in tail extend case, log.log might be empty
364563a librbd: acquire cache_lock before refreshing parent
110c354 ReplicatedPG::promote_object: check scrubber and block if necessary
5404fbf common: do not unlock rwlock on destruction
a73a4cb common/RWLock: track read/write locks via atomics for assertion checks

rados

run=loic-2015-04-21_10:20:06-rados-firefly-backports---basic-multi eval filter=$(curl --silent http://paddles.front.sepia.ceph.com/runs/$run/jobs/?status=dead | jq '.[].description' | while read description ; do echo -n $description, ; done | sed -e 's/,$//') ./virtualenv/bin/teuthology-suite --filter "$filter" --priority 1000 --suite rados --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --owner loic@dachary.org --ceph firefly-backports ./virtualenv/bin/teuthology-suite --filter-out btrfs,ext4 --priority 1000 --suite rados --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --owner loic@dachary.org --ceph firefly-backports

rbd

run=loic-2015-04-21_10:32:12-rbd-firefly-backports---basic-multi eval filter=$(curl --silent http://paddles.front.sepia.ceph.com/runs/$run/jobs/?status=fail | jq '.[].description' | while read description ; do echo -n $description, ; done | sed -e 's/,$//') ./virtualenv/bin/teuthology-suite --filter "$filter" --priority 1000 --suite rbd --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --owner loic@dachary.org --ceph firefly-backports ./virtualenv/bin/teuthology-suite --priority 1000 --suite rbd --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email xinxin.shu@intel.com --owner loic@dachary.org --ceph firefly-backports

teuthology run commit:c2d5a327533cef8a4140a20e398891b4ce0026be (integration branch march 2015)

$ git log --no-merges --oneline c844a68d591221034689afa98601d30c7ba9812a..c2d5a327533cef8a4140a20e398891b4ce0026be
110c354 ReplicatedPG::promote_object: check scrubber and block if necessary
43053fc ceph-objectstore-tool: Use exit status 11 for incompatible import attempt
9437cb1 ceph-objectstore-tool: Output only unsupported features when incomatible
3160e8d init-radosgw*: don't require rgw_socket_path to be defined
cddbff9 doc,tests: force checkout of submodules
63b39db osd: fix negative degraded objects during backfilling
7e85722 doc: Minor fixes to ceph command manpage
9ac488c doc: Fix ceph command manpage to match ceph -h (firefly)
5f1245e rados.py: keep reference to python callbacks
cf366fc doc: Changes format style in ceph to improve readability as html.
07fc9f6 mds: fix assertion caused by system clock backwards
8a25a51 rgw: fail s3 POST auth if keystone not configured
9074eb7 rgw: check for timestamp for s3 keystone auth

rados

./virtualenv/bin/teuthology-suite --filter-out btrfs,ext4 --priority 101 --suite rados --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

teuthology run commit:c844a68d591221034689afa98601d30c7ba9812a (integration branch march 2015)

rados

run=loic-2015-03-11_18:54:32-rados-firefly-backports---basic-multi
eval filter=$(curl --silent http://paddles.front.sepia.ceph.com/runs/$run/jobs/?status=fail | jq '.[].description' | while read description ; do echo -n $description, ; done | sed -e 's/,$//')
./virtualenv/bin/teuthology-suite --filter "$filter" --priority 101 --suite rados --suite-branch wip-cot-firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org  --ceph firefly-backports
./virtualenv/bin/teuthology-suite --filter-out btrfs,ext4 --priority 101 --suite rados --suite-branch wip-cot-firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

rgw

Re-run with ceph-qa-suite patch create a new get_acl helper to ensure proper xml is compared

run=loic-2015-03-16_12:57:30-rgw-firefly-backports---basic-multi
eval filter=$(curl --silent http://paddles.front.sepia.ceph.com/runs/$run/jobs/?status=fail | jq '.[].description' | while read description ; do echo -n $description, ; done | sed -e 's/,$//')
./virtualenv/bin/teuthology-suite --filter="$filter" --priority 101 --suite rgw --suite-branch wip-rgw-acl --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

run=loic-2015-03-11_19:06:39-rgw-firefly-backports---basic-multi
eval filter=$(curl --silent http://paddles.front.sepia.ceph.com/runs/$run/jobs/?status=fail | jq '.[].description' | while read description ; do echo -n $description, ; done | sed -e 's/,$//')
./virtualenv/bin/teuthology-suite --filter="$filter" --priority 101 --suite rgw --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports
./virtualenv/bin/teuthology-suite --priority 101 --suite rgw --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

rbd

./virtualenv/bin/teuthology-suite --priority 101 --suite rbd --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

fs

./virtualenv/bin/teuthology-suite -k testing --priority 101 --suite fs --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

teuthology run commit:b0d9b862d7f1a9a98cf4b41ff7cb0eb428740633 (march 2015)

rados

./virtualenv/bin/teuthology-suite --filter-out btrfs,ext4 --priority 101 --suite rados --suite-branch firefly --machine-type plana,burnupi,mira --distro ubuntu --email loic@dachary.org --owner loic@dachary.org --ceph firefly-backports

QE Validation

Suite Runs Notes/Issues
rados http://pulpito.ceph.com/teuthology-2015-06-04_11:23:35-rados-firefly---basic-multi/ FAILED #11914 Sam approved to release
http://pulpito.ceph.com/teuthology-2015-06-06_08:25:53-rados-firefly---basic-multi/
rbd http://pulpito.ceph.com/teuthology-2015-06-04_11:17:30-rbd-firefly---basic-multi/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-09_14:20:01-rbd-firefly---basic-multi/
rgw http://pulpito.ceph.com/teuthology-2015-06-05_11:11:05-rgw-firefly---basic-multi/ PASSED
fs http://pulpito.ceph.com/teuthology-2015-06-04_11:19:50-fs-firefly-testing-basic-multi/ PASSED
http://pulpito.ceph.com/ubuntu-2015-06-08_11:08:27-fs-firefly---basic-multi/
krbd http://pulpito.ceph.com/teuthology-2015-06-04_11:20:26-krbd-firefly-testing-basic-multi/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-09_13:27:01-krbd-firefly-testing-basic-multi/
kcephfs http://pulpito.ceph.com/teuthology-2015-06-16_08:03:47-kcephfs-firefly-testing-basic-multi/ PASSED
samba http://pulpito.ceph.com/teuthology-2015-06-04_11:21:27-samba-firefly---basic-multi/ FAILED #6613 Greg approved to release
http://pulpito.ceph.com/ubuntu-2015-06-08_11:05:13-samba-firefly---basic-multi/
ceph-deploy http://pulpito.ceph.com/teuthology-2015-06-04_11:31:09-ceph-deploy-firefly---basic-multi/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-12_10:43:35-ceph-deploy-firefly---basic-multi/
http://pulpito.ceph.com/teuthology-2015-06-14_10:14:51-ceph-deploy-firefly---basic-vps/
upgrade/dumpling-x (to firefly) http://pulpito.ceph.com/teuthology-2015-06-10_08:37:31-upgrade:dumpling-x-firefly---basic-multi/ PASSED
upgrade/dumpling-x (to firefly)(distros) http://pulpito.ceph.com/teuthology-2015-06-14_19:13:05-upgrade:dumpling-x-firefly-distro-basic-vps/ PASSED #11922, some env noise
upgrade/firefly http://pulpito.ceph.com/teuthology-2015-06-04_13:37:43-upgrade:firefly-firefly-distro-basic-multi/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-09_13:41:16-upgrade:firefly-firefly---basic-multi/
upgrade/firefly(distros) http://pulpito.ceph.com/teuthology-2015-06-12_17:00:02-upgrade:firefly-firefly-distro-basic-vps/ PASSED #11957
http://pulpito.ceph.com/teuthology-2015-06-14_09:04:15-upgrade:firefly-firefly---basic-vps/
http://pulpito.ceph.com/teuthology-2015-06-17_14:31:48-upgrade:firefly-firefly---basic-vps/
upgrade/dumpling-firefly-x (to hammer) http://pulpito.ceph.com/teuthology-2015-06-05_11:09:59-upgrade:dumpling-firefly-x-hammer-distro-basic-multi/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-08_15:12:25-upgrade:dumpling-firefly-x-hammer-distro-basic-multi/
upgrade/dumpling-firefly-x (to hammer)(distros) http://pulpito.ceph.com/teuthology-2015-06-11_13:59:30-upgrade:dumpling-firefly-x-v0.94.1-distro-basic-vps/ FAILED
this suite runs out of memory on VPS and unrunnable
http://pulpito.ceph.com/teuthology-2015-06-12_11:01:11-upgrade:dumpling-firefly-x-v0.94.1-distro-basic-vps/
upgrade/dumpling-firefly-x (to giant)(distros) http://pulpito.ceph.com/teuthology-2015-06-10_18:15:04-upgrade:dumpling-firefly-x-giant-distro-basic-vps/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-12_11:06:48-upgrade:dumpling-firefly-x-giant-distro-basic-vps/
upgrade/firefly-x (to giant)(distros) http://pulpito.ceph.com/teuthology-2015-06-10_18:18:01-upgrade:firefly-x-giant-distro-basic-vps/ PASSED
http://pulpito.ceph.com/teuthology-2015-06-12_10:50:33-upgrade:firefly-x-giant-distro-basic-vps/
powercycle http://pulpito.ceph.com/teuthology-2015-06-11_09:35:27-powercycle-firefly-testing-basic-multi/ PASSED issues found #11937, #11970
http://pulpito.ceph.com/teuthology-2015-06-12_10:30:45-powercycle-firefly-testing-basic-multi/
http://pulpito.ceph.com/teuthology-2015-06-15_10:58:49-powercycle-firefly-testing-basic-multi/
FAILED / PASSED

History

#1 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#2 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#3 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#4 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#5 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#6 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#7 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#8 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#9 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#10 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#11 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#12 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#13 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#14 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#15 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#16 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#17 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#18 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#19 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#20 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#21 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#22 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#23 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#24 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#25 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#26 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#27 Updated by Loic Dachary over 3 years ago

  • Tracker changed from Bug to Tasks
  • Project changed from Ceph to Stable releases

#28 Updated by Loic Dachary over 3 years ago

  • Priority changed from Low to Urgent

#29 Updated by Loic Dachary over 3 years ago

  • Subject changed from release firefly v0.80.10 to firefly v0.80.10

#30 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#31 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#32 Updated by Loic Dachary over 3 years ago

  • Target version set to 452

#33 Updated by Loic Dachary over 3 years ago

  • Assignee changed from Loic Dachary to Xinxin Shu

#34 Updated by Loic Dachary over 3 years ago

  • translation missing: en.field_release set to 5

#35 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#36 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#37 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#38 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#39 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#40 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#41 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#42 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#43 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#44 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#45 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#46 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#47 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#48 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#49 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#50 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#51 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#52 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#53 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#54 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#55 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#56 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#57 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#58 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#59 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#60 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#61 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#62 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#63 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#64 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#65 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#66 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#67 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#68 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#69 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#70 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#71 Updated by Loic Dachary over 3 years ago

  • translation missing: en.field_release set to 8

#72 Updated by Loic Dachary over 3 years ago

  • Target version changed from 452 to v0.80.10

#73 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#74 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#75 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#76 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#77 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)
  • changed "Branch to build from" to reflect last-minute backport
  • changed Sam's rados approval to "YES" based on IRC discussion

#78 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)

#79 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#80 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#81 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#82 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#83 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#84 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#85 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#86 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#87 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#88 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#89 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#90 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#91 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#92 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#93 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#94 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#95 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#96 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#97 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#98 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#99 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#100 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#101 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#102 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#103 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#104 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#105 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#106 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#107 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#108 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#109 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#110 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#111 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#112 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#113 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#114 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#115 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#116 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#117 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#118 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#119 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#120 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#121 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#122 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#123 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#124 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#125 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#126 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#127 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#128 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#129 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#130 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#131 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#132 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#133 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#134 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#135 Updated by Yuri Weinstein over 3 years ago

  • Description updated (diff)

#136 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)

#137 Updated by Loic Dachary over 3 years ago

git --no-pager log --format='%H %s' --graph tags/v0.80.9..tags/v0.80.10 | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#138 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)
  • Status changed from In Progress to Resolved

#139 Updated by Loic Dachary almost 3 years ago

#140 Updated by Loic Dachary almost 3 years ago

Also available in: Atom PDF