Project

General

Profile

Fix #9694

libzmq 4.x is API-incompatible; safer to use 3.x

Added by Dan Mick almost 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Backend (packaging/deployment)
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743508 and https://github.com/hintjens/libzmq/commit/cac0f9838d987a0534e34fe141017657ffcb9ff9 in response. I think it would be safer to use 3.2.5, and have asked the libzmq author to cut an upstream release, and he has agreed to do so.

Once that's available, we'll probably have to build it for all the supported ICE releases until the downstreams catch up.

History

#1 Updated by Dan Mick almost 7 years ago

  • Tracker changed from Bug to Fix

#2 Updated by Dan Mick over 6 years ago

  • Target version changed from 1.3 backlog to 1.3-dev9

#3 Updated by Neil Levine over 6 years ago

  • Target version changed from 1.3-dev9 to 1.3-dev10

#4 Updated by Dan Mick over 6 years ago

  • Target version changed from 1.3-dev10 to 1.3-dev11

#5 Updated by Christina Meno over 6 years ago

  • Target version changed from 1.3-dev11 to 1.3-dev12

#6 Updated by Christina Meno over 6 years ago

  • Target version changed from 1.3-dev12 to 1.3-dev13

#7 Updated by Christina Meno over 6 years ago

  • Target version changed from 1.3-dev13 to 1.3-rc1

#8 Updated by Dan Mick almost 5 years ago

  • Assignee changed from Dan Mick to Christina Meno

I suspect this is irrelevant now.

#9 Updated by Patrick Donnelly over 1 year ago

  • Status changed from 12 to New

#10 Updated by Dan Mick about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF