Project

General

Profile

Bug #963

osd: errors part way through multiple ops leave inconsistent object context

Added by Sage Weil about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

we bail out and do nothing, but leave behind a partial set of changes to the cached object context(s).

we need to either discard everything, or partially apply the mutation...

History

#1 Updated by Sage Weil about 9 years ago

  • Target version changed from v0.27 to v0.28

#2 Updated by Greg Farnum about 9 years ago

You're talking about ObjectOperations here? I vote for discard everything, since those are supposed to be more or less atomic...

#3 Updated by Sage Weil almost 9 years ago

  • Assignee set to Sage Weil

#4 Updated by Sage Weil almost 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF