Project

General

Profile

Bug #9602

rbd export -> nc ->rbd import = memory leak

Added by Irek Fasikhov over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I see a memory leak when importing raw devi?e.

Export Scheme:
[rbd@rbdbackup ~]$ rbd --no-progress -n client.rbdbackup -k /etc/ceph/big.keyring -c /etc/ceph/big.conf export rbdtest/vm-111-disk-1 - | nc 10.43.255.252 12345

[root@ct2 ~]# nc -l 12345 | rbd import --no-progress --image-format 2 - rbd/vm-111-disk-1

This is the same problem with ssh.
Memory usage, see the screenshots.

OS: CentOS 6.5
Kernel: 2.6.32-431.el6.x86_64
Ceph --version: ceph version 0.72.2 (a913ded2ff138aefb8cb84d347d72164099cfd60)

178.png View (115 KB) Irek Fasikhov, 09/26/2014 05:26 AM

179.png View (122 KB) Irek Fasikhov, 09/26/2014 05:26 AM

180.png View (56.4 KB) Irek Fasikhov, 09/26/2014 05:26 AM

message.log View (25.3 KB) Irek Fasikhov, 09/26/2014 05:26 AM

History

#1 Updated by Sage Weil over 5 years ago

  • Project changed from Ceph to rbd
  • Category deleted (librbd)
  • Priority changed from Normal to High

#2 Updated by Sage Weil over 5 years ago

  • Priority changed from High to Urgent

#3 Updated by Irek Fasikhov over 5 years ago

Hi, Sage.

I'm sorry, was wrong to put up parameter: rbd_cache size
The problem is not confirmed.

#4 Updated by Irek Fasikhov over 5 years ago

As a suggestion, prohibit the use of the cache when RDB imports.

#5 Updated by Jason Dillaman over 5 years ago

I quickly attempted to reproduce this on the same version w/o success. Can you attach /etc/ceph/big.conf? How large is the image that you are importing?

#6 Updated by Josh Durgin over 5 years ago

  • Status changed from New to Need More Info

#7 Updated by Irek Fasikhov over 5 years ago

Jason Dillaman wrote:

I quickly attempted to reproduce this on the same version w/o success. Can you attach /etc/ceph/big.conf? How large is the image that you are importing?

Hi, Jason.

It was not a mistake in the code, I made ??a mistake with the parameter rbd_cache_size:
rbd_cache size = 134217728000 //130 GB :)

#8 Updated by Jason Dillaman over 5 years ago

  • Status changed from Need More Info to Closed

Irek, thanks for the update. Closing as not a bug.

Also available in: Atom PDF