Project

General

Profile

Bug #9322

OSDMap updates from pgmap can be delayed indefinitely

Added by Greg Farnum almost 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Category:
Monitor
Target version:
-
Start date:
09/02/2014
Due date:
% Done:

0%

Source:
Support
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Like #9321, but in the other direction: we try to update the osdmap from the pgmap in OSDMonitor::tick(), but if pgmonitor->is_readable() fails, we just ignore it. As with the other bug, in our current implementation we should be safe to read the pgmap at any time because it's always consistent, even if we know it to be stale.

Beyond that, there is no output at any debug level if we fail to do the work, and we don't schedule a Context to retry. If this remains conditional we need to do something to make sure the work happens eventually, and add debug output at an appropriate level so we can trace actual activity as it happens.

Associated revisions

Revision 06fc39c8 (diff)
Added by Joao Eduardo Luis almost 5 years ago

mon: PaxosService: can be readable even if proposing

As long as we have a stable version in memory that is lower or equal to
the version we want.

Fixes: #9321
Fixes: #9322

Signed-off-by: Joao Eduardo Luis <>

History

#1 Updated by Sage Weil almost 5 years ago

  • Assignee set to Joao Eduardo Luis

#2 Updated by Joao Eduardo Luis almost 5 years ago

  • Status changed from New to In Progress

#3 Updated by Joao Eduardo Luis almost 4 years ago

  • Status changed from In Progress to Resolved
  • Regression set to No

Also available in: Atom PDF