Project

General

Profile

Bug #915

kclient corrupts on direct_io? ceph_direct_io_test reliably hoses the client machine

Added by Anonymous over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
03/22/2011
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

  • ceph_direct_io_test (job 261)
    14:08:37 DEBUG| Running '/usr/local/autotest/tests/direct_io_test/src/direct_io_test'
    14:08:48 DEBUG| [stdout] ..........
    14:08:48 DEBUG| [stdout] do_o_direct_reads: SUCCESS
    14:08:48 INFO | Test finished after 1 iterations.

but

14:08:48 INFO | CmdError: Command <grep MemTotal /proc/meminfo> failed, rc=-11, Command returned non-zero exit status

grep segfaulting? ssh closes connections early. serial console fails too!

sepia63 login: ubuntu
Segmentation fault (core dumped)
Segmentation fault (core dumped)
Segmentation fault (core dumped)
Linux sepia63 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64 GNU/Linux

Welcome to Ubuntu! * Documentation: https://help.ubuntu.com/

Ubuntu 10.10 sepia63 ttyS0

sepia63 login:

i have seen this before, cause is still unclear.. powercycling
rerunning as job 266

  • ceph_direct_io_test (job 266)
    exact same symptoms as with earlier run
    it seems direct_io_test hoses a ceph installation bad enough that exec segfaults reliably

History

#1 Updated by Sage Weil over 8 years ago

  • Project changed from Ceph to Linux kernel client
  • Priority changed from Normal to High

#2 Updated by Sage Weil over 8 years ago

  • Target version set to v2.6.39
  • translation missing: en.field_position set to 1
  • translation missing: en.field_position changed from 1 to 538

#3 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position deleted (538)
  • translation missing: en.field_position set to 533

#4 Updated by Anonymous over 8 years ago

Can't reproduce anymore, apparently some of the recent commits fixed this.
jobs 289 & 290 are both happy. Will re-run over the weekend, re-open on Monday if this really happens again.

#5 Updated by Anonymous over 8 years ago

  • Status changed from New to Resolved

Whoops, forgot to actually mark resolved.

Also available in: Atom PDF