Project

General

Profile

Bug #8727

Firefly monitors send incompatible messages to older monitors

Added by Greg Farnum about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Urgent
Category:
Monitor
Target version:
-
Start date:
07/02/2014
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

MForward got revved to a new version that requires Firefly monitors to decode. That doesn't work if you upgrade peons before leaders.

Associated revisions

Revision c92feebb (diff)
Added by Joao Eduardo Luis about 5 years ago

messages: MForward: fix compat version

A while ago we bumped the head version and reset the compat version to 0.
Doing this so happens to make the messenger assume that the message does
not support the compat versioning and sets the compat version to the head
version -- thus making compat = 2 when it should have been 1.

The nasty side-effect of this is that upgrading from emperor to firefly
will have emperor-leaders being unable to decode forwarded messages from
firefly-peons.

Fixes: #8727

Signed-off-by: Joao Eduardo Luis <>

Revision 4733178c (diff)
Added by Joao Eduardo Luis about 5 years ago

messages: MForward: fix compat version

A while ago we bumped the head version and reset the compat version to 0.
Doing this so happens to make the messenger assume that the message does
not support the compat versioning and sets the compat version to the head
version -- thus making compat = 2 when it should have been 1.

The nasty side-effect of this is that upgrading from emperor to firefly
will have emperor-leaders being unable to decode forwarded messages from
firefly-peons.

Fixes: #8727

Signed-off-by: Joao Eduardo Luis <>
(cherry picked from commit c92feebb81f90344a085f8256f0ed03cdc2f14e1)

History

#1 Updated by Joao Eduardo Luis about 5 years ago

  • Backport set to firefly

Looks like the issue is that MForward's COMPAT version was set to 0 on b4fbe4f8; according to Sage that has the messenger believe that it's an old client that didn't understand compat versions and so the compat version is set to the head version (in this case, 2).

I will push a patch to fix the COMPAT version to 1 and backport it to firefly.

#2 Updated by Joao Eduardo Luis about 5 years ago

  • Status changed from New to Need Review

#3 Updated by Sage Weil about 5 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF