Project

General

Profile

Bug #8721

Calamari on RHEL does not come up after reboot.

Added by Warren Usui about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Backend (packaging/deployment)
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

If you reboot the Calamari server, the UI cannot connect back.

The problem is probably due to all sorts of services not restarting.
Apache does not restart, for example. This may be a problem with yum
services in general.

History

#1 Updated by Dan Mick about 7 years ago

So I note that chkconfig httpd says

Note: Forwarding request to 'systemctl is-enabled httpd.service'.
disabled

which doesn't look good. Investigating further.

#2 Updated by Dan Mick about 7 years ago

  • Category set to Backend (packaging/deployment)
  • Status changed from New to 12
  • Assignee set to Dan Mick
  • Priority changed from Normal to Urgent
  • Source changed from other to Q/A

#3 Updated by Dan Mick about 7 years ago

The same is true of supervisord. I guess this is a difference between the packages on RHEL7 vs RHEL<7, and I guess adding chkconfig on for both should be harmless < 7 and critical >=7.

#4 Updated by Dan Mick about 7 years ago

  • Status changed from 12 to In Progress

#5 Updated by Warren Usui about 7 years ago

Note: This also happens on Centos 6.5

#6 Updated by Dan Mick about 7 years ago

  • Subject changed from Calamari on RHEL 7 does not come up after reboot. to Calamari on RHEL does not come up after reboot.

So, from a discussion on #systemd, I am now under the impression that Fedora et. al. expect part of the app installation process to include "instruct the user as to how to run chkconfig on/service start or systemctl enable/systemctl start for all services you depend on."

This strikes me as mildly insane, so I want to check this assertion with RedHat people who might pose as experts on how apps should deal with system services. One thought is to include such things in calamari-ctl initialize, perhaps with explicit confirmation from the user if someone feels that's necessary.

(I get the "don't enable network listens unless I explicitly allow it", but that's in conflict with the "install the application and get it to work", and I need to understand what the right resolution of that tension is.)

#7 Updated by Dan Mick about 7 years ago

(because the same is true for salt-master.)

#8 Updated by Dan Mick about 7 years ago

httpd and salt-master are both restarted by calamari-server's postinstall; supervisord is restarted by calamari-ctl initialize. So the existing packages should have started all three services, but nothing enabled them to start on boot.

#9 Updated by Dan Mick about 7 years ago

  • Status changed from In Progress to Fix Under Review

wip-8721 seems to work on rhel7.

#10 Updated by Dan Mick about 7 years ago

  • Status changed from Fix Under Review to Resolved

#11 Updated by Dan Mick about 7 years ago

Fixed in 1.2 commit 1a7f62a06daa2864d2c36fb022c0d5533fe7bb26

#12 Updated by Dan Mick about 7 years ago

  • Target version set to v1.2-rc4

Also available in: Atom PDF