Project

General

Profile

Tasks #863

Bug #859: Ceph does not pass fsstress

osd spinning during fsstress

Added by Greg Farnum almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

During some fsstress runs, I've managed to end up with an OSD spinning at 100% cpu, making no apparent progress, which the monitor thinks is down. This is running on kai with btrfs. The first time I thought it dismissed it as an unfortunate interaction between cfuse (running in my source dir) and the OSD (running in a different part of my source dir, but on the same btrfs partition).
Then I reproduced with the cfuse mount in a completely separate drive.

History

#1 Updated by Samuel Just almost 9 years ago

This seems to be caused by the following chain:

1) bufferlist iterator copy from a bufferlist containing one empty bufferpointer loops forever
2) filestore::read on an empty file seems to result in a bufferlist containing one empty bufferptr

TMAPUP op calls 1) with 2) since iterator to the beginning of 2) is not equal to end().

Will fix on monday.

#2 Updated by Samuel Just almost 9 years ago

  • Status changed from New to Resolved

should be fixed in 67c8b91dd5a9ea6fd508b7544e397154ba330142

Also available in: Atom PDF