Project

General

Profile

Tasks #860

Bug #859: Ceph does not pass fsstress

mds rstat assert failure on fsstress

Added by Greg Farnum almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

100%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

This is during an unlink.

mds/MDCache.cc: 1736: FAILED assert(!"negative rstat rbytes" == g_conf.mds_verify_scatter)

Logs and cores are available in kai:~gregf/logs/fsstress/unlink_failure


Subtasks

fs - Subtask #879: Implement function to check fragstat and rstat on CDirsResolvedGreg Farnum

History

#1 Updated by Greg Farnum over 8 years ago

Looked at this with Sage, and we're stumped. Hopefully this will become easier to reproduce once we deal with the other bugs fsstress is turning up, and we can add more debugging and stuff then.

#2 Updated by Sage Weil over 8 years ago

  • Estimated time set to 0.00 h

#3 Updated by Greg Farnum over 8 years ago

  • Status changed from In Progress to 7
  • Estimated time set to 0.00 h

Looks like we fixed this without noticing in one of the bugfixes we pushed to wip_mds_rstats. Doing one last run to check my updated code against this, then closing!

#4 Updated by Greg Farnum over 8 years ago

Not seeing this any more.

#5 Updated by Greg Farnum over 8 years ago

  • Status changed from 7 to Resolved

Also available in: Atom PDF