Project

General

Profile

Fix #8455

UI: Dashboard IOPS graph fails to render

Added by Yan-Fa Li over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
UI
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

If the Dashboard UI isn't visible yet, e.g. you jump into workbench or graph, this can cause dygraph to not render it's graph. We need to use a similar strategy to PGMAP and force a rendering cycle. This is caused by canvas elements not being rendered correctly when they are outside of the current viewport.

How to reproduce:

1. enter manage -> enter graph -> enter dashboard
2. no iops graph is rendered

Take a look at pgmap and force a re-render when jumping back to dashboard.

Associated revisions

Revision bcc5b33b (diff)
Added by Yan-Fa Li over 7 years ago

Fix #8455: Dashboard IOPS graph fails to render

- hook into dashboard:refresh event and force a
redraw.

Signed-off-by: Yan-Fa Li <>

History

#1 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to Resolved

Master branch, commit bcc5b33b18b07b9b7c3edb732275e5b1b883904f

Also available in: Atom PDF