Project

General

Profile

Bug #8350

UI: IOPs count frequently displays 0 incorrectly

Added by John Spray over 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

When selecting the most recent IOPs value, the UI code takes the last time interval in the graphite data, and uses it, or 0 if it is null.

The last value is actually null pretty often, because the intervals provided correspond to the time period requested (i.e. up to now), including a null for the end of the requested time period if that interval hasn't seen a sample yet.

Due to aliasing, you may also see a null in the data every once in a while, e.g. if we're sampling every 60 seconds and also polling every 60 seconds, every once in a while our poll might take 60.1 seconds and we'll get a 60 second period with no data.

Anyway, the upshot is that when getting the "latest value" from a series of graphite datapoint, the algorithm to use is: * Latest value if it's not null * Else if the latest-but-one is not null, use that * Else if the latest-but-two is not null, use that * Else the data in unavailable (display zero or better yet something to indicate absent data like "-").

I'm still intending that we should have some fast "latest value" cache in the future to supply unambiguous latest values so that API clients don't have to scrape them from the time series, but for the moment the front end is the right place to fix this.

This is fairly high severity, because that large IOPs number is so prominent.

Screen Shot 2014-05-14 at 10.36.24.png View (186 KB) John Spray, 05/14/2014 02:40 AM

History

#1 Updated by John Spray over 7 years ago

Attached: example of some dirty stats data from a less-than-perfectly-behaved cluster which is missing its stats intervals every few minutes.

#2 Updated by Yan-Fa Li over 7 years ago

  • Subject changed from IOPs count frequently displays 0 incorrectly to UI: IOPs count frequently displays 0 incorrectly

#3 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to 7

branch ui-fixes-rc1, commit 9b3f7d66cb3171ff422fee0a1589e2966e65109d

Use the last 3 values from graphite. Use the most recent non-null value for the IOPS display.

#4 Updated by Ian Colle about 7 years ago

  • Assignee deleted (Yan-Fa Li)

#5 Updated by Dan Mick about 7 years ago

  • Status changed from 7 to Resolved

The fix for this has been merged.

Also available in: Atom PDF