Project

General

Profile

Bug #8142

regression on api/v1/cluster/<FSID>/space

Added by Yan-Fa Li over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Backend (REST API)
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

The Usage widget is broken because the backend seems to be returning nulls

HTTP 200 OK
Vary: Accept
Content-Type: text/html; charset=utf-8
Allow: GET, HEAD, OPTIONS

{
"space": {
"free_bytes": null,
"used_bytes": null,
"capacity_bytes": null
}
}

History

#1 Updated by John Spray over 7 years ago

  • Status changed from 12 to Rejected

You're talking specifically about mira106, right? This is happening because it's not running the latest diamond on the ceph nodes.

Also available in: Atom PDF