Project

General

Profile

Feature #8071

erasure-code: simplify jerasure initialization

Added by Loic Dachary almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

100%

Source:
other
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

Take advantage of the newly exposed galois_init_default_field function to simplify jerasure initialization


Related issues

Related to Ceph - Bug #7914: osd: SEGV on ec write, ErasureCodeJerasure: encode adjusted buffer length from 4096 to 4096 Resolved 03/31/2014

Associated revisions

Revision e29beff3 (diff)
Added by Loic Dachary almost 6 years ago

erasure-code: remove jerasure internals dependencies

Use the galois_init_default_field() function instead of implementing it
in the init function of the ErasureCodeJerasure plugin. It removes
dependencies to internal variables of the jerasure library that are
subject to change because they are not part of the published API.

http://tracker.ceph.com/issues/8071 Fixes: #8071

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loic Dachary almost 6 years ago

  • Assignee set to Loic Dachary

#2 Updated by Loic Dachary almost 6 years ago

  • Target version set to 0.83

#3 Updated by Loic Dachary almost 6 years ago

  • Status changed from 12 to In Progress

#5 Updated by Loic Dachary almost 6 years ago

  • Status changed from In Progress to Fix Under Review

#7 Updated by Loic Dachary almost 6 years ago

  • Status changed from Fix Under Review to 7
  • % Done changed from 0 to 80

#8 Updated by Loic Dachary almost 6 years ago

Fail to run the rados test suite probably a teuthology local problem, investigating.

ConnectionError: HTTPConnectionPool(host='paddles.front.sepia.ceph.com', port=80): Max retries exceeded with url: /runs/loic-2014-06-13_17:29:15-rados-wip-8071-testing-basic-plana/jobs/ (Caused by &lt;class 'gevent.dns.DNSError'>: [Errno 2] server failed)

#9 Updated by Loic Dachary almost 6 years ago

tests queued

no clue why queuing the tests failed before, just happy it succeeds now ;-)

#10 Updated by Ian Colle almost 6 years ago

  • Target version changed from 0.83 to 0.83 cont.

#11 Updated by Loic Dachary almost 6 years ago

  • Status changed from 7 to Resolved
  • % Done changed from 80 to 100

Was merged before testing it individually.

Also available in: Atom PDF