Project

General

Profile

Bug #8024

kclient: misdirected osd request

Added by Greg Farnum over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
04/07/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

teuthology:/a/teuthology-2014-04-06_23:01:04-kcephfs-master-testing-basic-plana/175847

2014-04-07T08:01:21.466 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:94: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:95: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:96: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:97: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:98: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:99: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:100: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:101: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.467 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: Makefile:102: warning: NUL character seen; rest of line ignored
2014-04-07T08:01:21.468 INFO:teuthology.task.workunit.client.0.err:[10.214.132.10]: make: *** No targets.  Stop.
2014-04-07T08:01:21.468 INFO:teuthology.task.workunit:Stopping suites/ffsb.sh on client.0...

That silly "NUL character" is for every line in the Makefile. Not sure if the test is broken or if something very strange happened to the file data.


Related issues

Duplicates Linux kernel client - Bug #7954: misdirected op Resolved 04/01/2014

History

#1 Updated by Zheng Yan over 5 years ago

  • Project changed from fs to Linux kernel client
  • Category deleted (53)

Maybe caused by:

gzip -cd /a/teuthology-2014-04-06_23:01:04-kcephfs-master-testing-basic-plana/175847/remote/ubuntu@plana69.front.sepia.ceph.com/log/ceph-osd.3.log.gz | grep WRN
2014-04-07 08:01:06.393421 7fe0e5455700  0 log [WRN] : client.4122 10.214.132.10:0/2550670732 misdirected client.4122.1:29 pg 0.17c5e6c5 to osd.3 not [5,3] in e7/7
2014-04-07 08:01:06.394031 7fe0e5c56700  0 log [WRN] : client.4122 10.214.132.10:0/2550670732 misdirected client.4122.1:31 pg 0.cf6d7fa5 to osd.3 not [5,3] in e7/7
2014-04-07 08:01:06.394083 7fe0e5455700  0 log [WRN] : client.4122 10.214.132.10:0/2550670732 misdirected client.4122.1:33 pg 0.83ee7d53 to osd.3 not [1,3] in e7/7
2014-04-07 08:01:06.394310 7fe0e5c56700  0 log [WRN] : client.4122 10.214.132.10:0/2550670732 misdirected client.4122.1:35 pg 0.e874eba2 to osd.3 not [1,3] in e7/7

Saw similar warning in other testing cases.

#2 Updated by Zheng Yan over 5 years ago

  • Subject changed from kclient: ffsb test failure to kclient: misdirected osd request
  • Assignee set to Ilya Dryomov

#3 Updated by Ilya Dryomov over 5 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF