Project

General

Profile

Bug #8010

It's impossible to remove unused filesystem pools from a cluster

Added by Greg Farnum over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
04/07/2014
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

We've inadvertently made it impossible to remove a filesystem from a Ceph cluster. If there is not data in the FS, it should be possible to remove the final data pool and metadata pool.

One option is to extend the "news" command to create a "blank" FS that doesn't contain anything.

Associated revisions

Revision 6a0dd1be (diff)
Added by John Spray about 5 years ago

Revert "mon: OSDMonitor: Refuse to delete CephFS pools"

This reverts commit c7d265a9b276aad5caf9b35f3ce8bc7bdd169f0f.

Because this pre-dates the `fs rm` command, this change was
preventing firefly users from ever deleting their filesystem pools.

Fixes: #8010

Signed-off-by: John Spray <>

History

#1 Updated by Maxym Kutsevol over 5 years ago

It's happening with
ceph version 0.78 (f6c746c314d7b87b8419b6e584c94bfe4511dbd4)
Linux access.car.dot.com 3.13.0-21-generic #43-Ubuntu SMP Mon Mar 31 22:52:24 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

#2 Updated by John Spray about 5 years ago

  • Status changed from New to In Progress
  • Assignee set to John Spray

#3 Updated by Sage Weil about 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF