Project

General

Profile

Bug #7945

installing calamari-server twice leaves package broken

Added by Dan Mick over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Backend (packaging/deployment)
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Scope of brokenness is unknown; the first symptom is that the symlink from /usr/bin/calamari-ctl to /opt/calamari is broken because /opt/calamari is empty. Need to carefully install and install again and see what's going on.

Associated revisions

Revision 888e0c5d (diff)
Added by Dan Mick over 7 years ago

calamari-server.postrm: only nuke directories in appropriate cases

Remove removes /opt/calamari (mostly .pyc files)
Purge removes those plus logs and whisper data

Fixes: #7945
Signed-off-by: Dan Mick <>

History

#1 Updated by Dan Mick over 7 years ago

This may be because postrm does a bunch of rm -rf's, and it looks like maybe postrm is called after the new packages' files are installed instead of between old and new. Verifying.

#2 Updated by Dan Mick over 7 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF