Project

General

Profile

Bug #794

massif is unusable on current code

Added by Greg Farnum over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When starting up valgrind stuff via vstart, it now logs everything to the console. I presume this is because of the changes that got made to logging, but it renders valgrind pretty much unuseable at this point.

I think I can do what I was attempting by using tcmalloc's profiling bits, but it'd be good if we could switch back to valgrind on-demand!

History

#1 Updated by Greg Farnum over 9 years ago

  • Status changed from New to Resolved
  • Assignee set to Greg Farnum

This seems to have been because of a bad setting in config for the foreground logging option. Simple enough to fix!
Pushed in 5d3a129fc0d25fb6bdc9ec4565c5a4215a132693

#2 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_story_points set to 1
  • translation missing: en.field_position set to 1
  • translation missing: en.field_position changed from 1 to 541

Also available in: Atom PDF