Project

General

Profile

Bug #7734

Workbench "sort by hosts" doesn't show hosts, grays HOST in slider, can't reset

Added by Dan Mick over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
UI
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Demonstrated to Yan on mira106. Yan's theory is that it's a problem with >160 OSDs in the grid, perhaps running off the end of an array.

History

#1 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to Resolved

Fixed on branch manage commit a509e38f2b252fad72efa52d2db0cbc6b315479f

- the original bug was caused by the rendering code not limiting the elements to the maximum size of the grid. (Fixed)
- increase the height of the Grid to 16, this increases the maximum elements to 256
- make grid rendering code respect the height and column values instead of hard coding values
- swap magic numbers for more descriptive variables
- move legend to top of viz
- make legend auto-position itself based on configuration

Also available in: Atom PDF