Project

General

Profile

Bug #7684

failed cfuse_workunit_kernel_untar_build.yaml test

Added by Greg Farnum over 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
03/11/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client
Labels (FS):
Pull request ID:

Description

http://qa-proxy.ceph.com/teuthology/teuthology-2014-03-09_23:00:25-fs-firefly-testing-basic-plana/124157/

The teuthology log just has it aborting on an ENOENT response for no apparent reason. The cfuse log has a lot of debugging on, but nothing that makes me think I've found the problem. :( There are some ENOENT responses (and ENODATA on xattrs) but they all look like the standard ones during lookups at first glance.

History

#1 Updated by Greg Farnum over 5 years ago

  • Priority changed from Normal to Urgent

#2 Updated by Zheng Yan over 5 years ago

2014-03-10 02:57:24.098482 7f9c5282f780  3 client.4100 ll_read 0x1ef6b50 10000008953  0~8192
2014-03-10 02:57:24.098485 7f9c5282f780 10 client.4100 get_caps 10000008953.head(ref=3 cap_refs={} open={1=1} mode=100664 size=7310 mtime=2012-02-29 16:32:49.000000 caps=pAsLsXsFscr(0=pAsLsXsFscr) objectset[10000008953 ts 0/0 objects 0 dirty_or_tx 0] parents=0x7f9c365626c0 0x7f9c36fa21e0) have pAsLsXsFscr need Fr want Fc but not Fc revoking -
2014-03-10 02:57:24.098515 7f9c5282f780 10 client.4100 readahead nr_consec_read 1 for 7310 bytes .. last_pos 0 .. offset 0

likely caused by inline data bug

#3 Updated by Zheng Yan over 5 years ago

  • Status changed from New to Testing

#4 Updated by Sage Weil over 5 years ago

  • Status changed from Testing to Resolved

#5 Updated by Greg Farnum about 3 years ago

  • Component(FS) Client added

Also available in: Atom PDF