Project

General

Profile

Bug #7580

The package librados2-0.77-0.el6.x86_64.rpm is corrupt and won't install

Added by Jasper Siero over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Sandon Van Ness
Category:
librados
Target version:
% Done:

100%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

While updating to the new 0.77 version of Ceph I encountered the following problem:

The new librados2 package is only 2.6 M and the previous packages are about 16 MB so it looks like the rpm is corrupt.

http://ceph.com/rpm-testing/el6/x86_64/librados2-0.75-0.el6.x86_64.rpm

librados2-0.76-0.el6.x86_64.rpm        05-Feb-2014 11:01   16M  
librados2-0.77-0.el6.x86_64.rpm 24-Feb-2014 19:58 2.6M

Updating : librados2-0.77-0.el6.x86_64 3/68
Error unpacking rpm package librados2-0.77-0.el6.x86_64
error: unpacking of archive failed on file /usr/lib64/librados.so.2.0.0;531474a0: cpio: read

librados2-0.75-0.el6.x86_64 was supposed to be removed but is not!
Verifying : librados2-0.75-0.el6.x86_64 46/68

Failed:
librados2.x86_64 0:0.75-0.el6 librados2.x86_64 0:0.77-0.el6

We are using CentOS 6.5

History

#1 Updated by Ian Colle over 6 years ago

  • Assignee set to Sandon Van Ness
  • Priority changed from High to Urgent

#2 Updated by Sandon Van Ness over 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Looks like the file was truncated during the copy process into the staging area. I re-did the repo's and re-sync'd with ceph.com and the file-size is as expected now and should be good.

I tested and was able to sucessfully install 77-0 from the testin centos RPM repo.

Also available in: Atom PDF