Project

General

Profile

Bug #7554

fs: "NoneType" object dereferences

Added by Greg Farnum over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/27/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

This is running the thrasher, so I assume it just continues to be broken:
http://qa-proxy.ceph.com/teuthology/teuthology-2014-02-23_23:02:50-fs-firefly-testing-basic-plana/99359/

History

#1 Updated by Greg Farnum over 5 years ago

  • Assignee set to John Spray

I'm giving this to you, John, just so that it doesn't get lost and because I thought you had made some fixes to the thrasher about the same error message earlier. We should discuss in the next standup.

#2 Updated by John Spray over 5 years ago

It'll be a different thing. mds_thrash is quite... loosely... written python. We're also not getting proper backtraces because the exception is getting printed from another greenlet. I'll do a pass over this code to see where else we're dereferencing Nones, and also fix it to give us useful backtraces.

#3 Updated by John Spray over 5 years ago

Could have been this: https://github.com/ceph/teuthology/commit/095a53c96fff75484d8d00d50b6d6a598579a81e

I'm hand testing my wip-7554 branch with this fix and better exception handling, PR to follow.

#4 Updated by John Spray over 5 years ago

  • Status changed from New to In Progress

#6 Updated by John Spray over 5 years ago

I think that PR is OK, although I haven't seen a clean run with it because of http://tracker.ceph.com/issues/7565

Also available in: Atom PDF