Project

General

Profile

Fix #7473

UI: transition rough between manage and workbench/graph

Added by Yan-Fa Li over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
UI
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Make the transition between the manage app and dashboard smoother, specifically when jumping directly to graph or workbench.

History

#1 Updated by Yan-Fa Li over 7 years ago

Known Issues:

- Flash of Dashboard before switching to Graphs or Workbench
- Workbench rendering issues due to canvas not being fully visible which causes SVG offset errors - possibly wait until visible before kicking off animation

#2 Updated by Yan-Fa Li over 7 years ago

Didn't get to it this sprint. Next one please.

#3 Updated by Dan Mick over 7 years ago

  • Target version changed from v1.2-dev4 to v1.2-dev5

#4 Updated by Yan-Fa Li over 7 years ago

I think the issue is that a certain API hasn't loaded yet, when the UI is trying to populate the dropdown. Normally this info is requested from another object which has previously been refreshed, this isn't true when we switch over to the UI element and the drop down doesn't get populated correctly.

I should probably delay letting the UI be usable until the data is loaded.

#5 Updated by Dan Mick over 7 years ago

Yan's update describes exactly what I see: moving from manage to graphs fails to fully populate the page-selection dialog.

#6 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to In Progress
  • translation missing: en.field_story_points changed from 1.0 to 2.0

#7 Updated by Yan-Fa Li over 7 years ago

  • Status changed from In Progress to Resolved

Fixed on manage branch commit e7e3958b9e738c6bb9b7c74b1dc961c44fd65a87

#8 Updated by Yan-Fa Li over 7 years ago

Fixes in this bug

- keep cards visibility: hidden during initial loading to prevent FOUC when jumping from manage to Workbench or Graph
- force a reset whenever we reload the workbench to prevent rendering errors due to calculations being made when display: none
- add a promise to OSD Viz which is only resolved once the collection has been loaded successfully once, this resolves the graph's not loading due to the host data not being loaded yet

Also available in: Atom PDF