Project

General

Profile

Bug #7451

updatedb will index /var/lib/ceph

Added by Sage Weil over 5 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
02/16/2014
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

See http://git.openvz.org/?p=vzctl;a=commitdiff;h=47334979b9b5340f84d84639b2d77a8a1f0bb7cf for one example of a package that add itself to the prune list.

I'm not sure the init script is the place to do it.. maybe the package postinst?

History

#1 Updated by Dietmar Maurer over 5 years ago

Sage Weil wrote:

I'm not sure the init script is the place to do it.. maybe the package postinst?

postinst is not good enough, because a later update of package 'mlocate' can overwrite the setting.

#2 Updated by Ken Dreyer over 5 years ago

This should also be reported to mlocate upstream (at Fedora) and to Red Hat for RHEL 7.

Here's the upstream updatedb.conf: http://pkgs.fedoraproject.org/cgit/mlocate.git/tree/updatedb.conf

To confirm, is "ceph" the proper filesystem type (from getmntent(3)->mnt_type ?)

EDIT: er, maybe we would need to simply exclude all /var/lib/ceph and not rely on mnt_type.

#3 Updated by Sage Weil over 5 years ago

  • Priority changed from Urgent to High

#4 Updated by Loic Dachary over 4 years ago

  • Backport changed from dumpling, emperor to hammer, firefly

schedule backport to LTS

#5 Updated by Ken Dreyer about 4 years ago

  • Assignee set to Ken Dreyer
  • Regression set to No

#7 Updated by Ken Dreyer about 4 years ago

  • Status changed from Verified to Pending Upstream
  • Backport deleted (hammer, firefly)

#9 Updated by Sage Weil over 2 years ago

  • Status changed from Pending Upstream to Resolved

Also available in: Atom PDF