Project

General

Profile

Bug #716

incorrect RESETSESSION hangs osd peering after wrongly marked down

Added by Sage Weil over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Saw this on playground during repeering. Cause seems to be that we _share_map_incoming on the rebound messenger while we are still marked down, causing a RESETSESSION later which makes us drop real messages.

History

#1 Updated by Sage Weil over 10 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF