Project

General

Profile

Bug #7127

PG status widget reports wrong number of PGs peering

Added by John Spray over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
UI
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

PG status appears to be showing the "replica count * n_peering" number, which I only noticed because the correct number is shown nearby in the health widget (screenshot attached). This is similar to the problem that existed before in the overall PG count that was fixed by using the number from the health counters instead.

Simple quick fix would be to remove this text from the pg status widget, leaving the correct text in the health widget.

Screen Shot 2014-01-10 at 13.38.38.png View (44.5 KB) John Spray, 01/10/2014 05:51 AM

History

#1 Updated by Yan-Fa Li over 7 years ago

I think the other fix is to get the data from the same source as the health widget. I think this value is derived from looking at the PG map. The overall count comes from the same source as the health widget so it should be safe to use that.

#2 Updated by Yan-Fa Li over 7 years ago

OK, I looked at this a bit more closely and using the same source as the health widget wouldn't be very reliable since it's a free form text field. I think another possible solution is to simply remove the number and report without the count, since it also includes replica's. This is probably going to become even more confusing once we have erasure encoding so maybe the time is right to remove the count from this particular view.

Another possibility is for us to add an API which returns accurate PG counts for the entire cluster without replicas which I could index into using the reporting PG key with the inflated counts to display some accurate info.

#3 Updated by Dan Mick over 7 years ago

It's also probably the case that not all of those PGs are "peering", because, again, that's a specific Ceph term that means a specific state, and we're trying to pick one of N "not completely perfect" verbs to jam all of them into...

#4 Updated by Christina Meno over 7 years ago

  • Assignee changed from Yan-Fa Li to Neil Levine

We need a call here what to do with the 548 peering label when more than one state exists. Do we delay for more accurate information or remove this label?

Recommendation remove number and replace it with "PGs".

#5 Updated by Neil Levine over 7 years ago

  • Assignee changed from Neil Levine to Yan-Fa Li

Let's remove the context info if we can't think of a succint way of saying "X are problematic".

#6 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to Resolved

Fixed on master commit bce453731d879bf783e4ef16cdde3273868ec920

Also available in: Atom PDF