Project

General

Profile

Bug #7098

Broken 'General Settings' and 'User'

Added by John Spray over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
UI
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

The general settings stuff is all hardcoded data. The hostname+ip+version data is in the works to be populated in wip-2.0.

The user pane has fields for changing the password, but they don't work (the backend part was never implemented in 1.x).

The simplest thing to do is hide the parts that don't work -- we're not losing any information by doing that. We can go back and add in functionality on the 1.x backend but that's not the ideal place to be adding new functionality.

Getting the user password thing sorted in 2.0 is #7097.

This ticket is for Neil's attention, to make a call about whether to disable the non-functioning elements, or do extra work on the 1.x backend to add this functionality.

History

#1 Updated by Neil Levine over 7 years ago

  • Assignee changed from Neil Levine to John Spray

I don't have access to a working Calamari install atm (mira is down and so is calamari.demo :-( ) so can't see what settings we expose that don't work. Off the top of my head , other than the API setting, I can't think of anything else that was MVP for 1.1 that needs to work.

#2 Updated by John Spray over 7 years ago

  • Assignee changed from John Spray to Yan-Fa Li

#3 Updated by Christina Meno over 7 years ago

  • Assignee changed from Yan-Fa Li to Neil Levine

We need more info here.

#4 Updated by Neil Levine over 7 years ago

Looks like nothing can be updated here so let's just grey everything out and remove the buttons.

#5 Updated by Neil Levine over 7 years ago

  • Assignee changed from Neil Levine to Yan-Fa Li

#6 Updated by Yan-Fa Li over 7 years ago

fixed on master commit 3c2595dc4a465cecdd4c9293bc6c6d291e7053d8

#7 Updated by Yan-Fa Li over 7 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF