Project

General

Profile

Bug #6961

create bucket add's new .bucket.meta file every time

Added by Dominik Mostowiec about 10 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
High
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer, firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

---
root@vm-1:/vol0/ceph/osd# find | grep meta | grep test1 | wc l
44
root@vm-1:/vol0/ceph/osd# s3 -u create test1
Bucket successfully created.
root@vm-1:/vol0/ceph/osd# find | grep meta | grep test1 | wc -l
46
--

.rgw.bucket size == 2,
after create (recreate) bucket in .rgw pool is (i think unnecessary) 1 file more every time.

Delete bucket do't remove meta this meta files.
--
root@vm-1:/vol0/ceph/osd# s3 u delete test1
root@vm-1:/vol0/ceph/osd# find | grep meta | grep test1 | wc -l
46
----

ceph: v0.67.4

History

#1 Updated by Loïc Dachary about 10 years ago

  • Project changed from Ceph to rgw
  • Category deleted (22)

#2 Updated by Yehuda Sadeh almost 9 years ago

  • Assignee set to Orit Wasserman
  • Priority changed from Normal to High
  • Backport set to hammer, firefly

#3 Updated by Yehuda Sadeh almost 9 years ago

This might have been fixed inadvertantly as part of the sharding work that was done for hammer. If it doesn't reproduce, we'll need to take a look at firefly.

#4 Updated by Yehuda Sadeh almost 9 years ago

  • Status changed from New to Resolved

We couldn't reproduce it, resolving it now. Might have been fixed previously.

Also available in: Atom PDF