Project

General

Profile

Bug #6608

samba teuthology dbench failure

Added by Greg Farnum almost 6 years ago. Updated 5 months ago.

Status:
Can't reproduce
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
10/21/2013
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Samba/CIFS
Pull request ID:

Description

2013-10-19T03:12:48.449 INFO:teuthology.task.workunit.client.1.out:[10.214.132.39]: [60483] open ./clients/client5/~dmtmp/COREL/@@@CDRW.TMP failed for handle 9982 (Not a directory)
2013-10-19T03:12:48.449 INFO:teuthology.task.workunit.client.1.out:[10.214.132.39]: (60484) ERROR: handle 9982 was not found

I didn't try to diagnose it at all.
/a/teuthology-2013-10-18_23:02:26-fs-master-testing-basic-plana/59779

History

#1 Updated by Greg Farnum almost 6 years ago

/a/teuthology-2013-10-20_02:13:10-fs-next-testing-basic-plana/60931/

#2 Updated by Greg Farnum almost 6 years ago

  • Priority changed from Normal to High

/a/teuthology-2013-10-20_19:01:21-fs-dumpling-testing-basic-plana/61466/

#3 Updated by Greg Farnum almost 6 years ago

/a/teuthology-2013-10-21_19:01:05-fs-dumpling-testing-basic-plana/63428/

#6 Updated by Zheng Yan almost 6 years ago

  • Status changed from New to Rejected

running dbench on local FS in parallel also results in similar failures.

#7 Updated by Greg Farnum almost 6 years ago

  • Status changed from Rejected to Need More Info

If samba is broken in this configuration we'll need to change our test (and report upstream, if we aren't using it incorrectly). Do you know if we're doing something particularly unusual, or this is a regression on their part?

#8 Updated by Zheng Yan almost 6 years ago

not sambe issue. It's wrong to run two instances of dbench on the same test directory.

#9 Updated by Greg Farnum almost 6 years ago

None of these failed tests are running it in parallel:

- workunit:
    clients:
      client.1:
      - suites/dbench.sh

And the workunit creates a separate dir for each client anyway; it's not sharing a directory.

At least, that's what's supposed to happen with these configs, and the only thing I see about multiple processes is when dbench itself starts up 10 on the second time through. What makes you think we're doing it wrong?

#10 Updated by Zheng Yan over 5 years ago

still see the issue ?

#11 Updated by Greg Farnum over 5 years ago

We're still occasional samba test failures, but I haven't diagnosed them carefully enough to know if they're this failure or the other one. I'll start doing that again soon.

#12 Updated by Greg Farnum over 5 years ago

  • Priority changed from High to Low

Demoting priority on samba.

#13 Updated by Zheng Yan over 5 years ago

  • Status changed from Need More Info to Can't reproduce

#14 Updated by Patrick Donnelly 5 months ago

  • Category deleted (43)
  • Labels (FS) Samba/CIFS added

Also available in: Atom PDF