Project

General

Profile

Subtask #6391

Fix #6116: osd: incomplete pg from thrashing on next

stuck incomplete

Added by Samuel Just about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

ubuntu@teuthology:/a/teuthology-2013-09-22_23:00:06-rados-master-testing-basic-plana/11735/

History

#1 Updated by Samuel Just about 6 years ago

overrides: [11/1828]
admin_socket:
branch: master
ceph:
conf:
global:
ms inject socket failures: 5000
mon:
debug mon: 20
debug ms: 1
debug paxos: 20
mon min osdmap epochs: 2
osd:
debug ms: 1
debug osd: 5
osd map cache size: 1
fs: xfs
log-whitelist:
- slow request
sha1: 08a97ae45f4df58a6a8ea8a6400934d860cf5eb4
ceph-deploy:
branch:
dev: master
conf:
client:
log file: /var/log/ceph/ceph-$name.$pid.log
mon:
debug mon: 1
debug ms: 20
debug paxos: 20
install:
ceph:
sha1: 08a97ae45f4df58a6a8ea8a6400934d860cf5eb4
s3tests:
branch: master
workunit:
sha1: 08a97ae45f4df58a6a8ea8a6400934d860cf5eb4
owner: scheduled_teuthology@teuthology
roles:
- - mon.a
- mon.c
- osd.0
- osd.1
- osd.2
- client.0
- - mon.b
- mds.a
- osd.3
- osd.4
- osd.5
- client.1
targets:
: ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDivON7Pi7nKT8Y2LyjOsLueldwYfhkyCgio+dfxc0t//nF4K0iiJ0OkirjMzmaTbBqxwyT+9fbCOXfZghja4DzXwGeqg8QQopsODkTSk9sKBeZOOxPVIyP0ky1nR8Kb6/Smgt+O+13eX/Xy8dsXm/9acbLSEEC5vRjTecKoY0WgM4dwkJZmwiB3OmkqusDfwX+uykel7XS5pfw7Pu3qosakptFXXoOzyTRvyWBNzwGDERmOphb
UlIatFV40E2Dg1UHHQ4B3RdAVa40LJerRsIU+o/IOea+yYo+yeo76HyLi1XcSUc3eT/rq4UIDKpQnKKPVqN+oWq3UdLk+lo706oH
: ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDcgpCHicDmX6yiwcSF/brGjqiupKPlQGhdn1mxRqOEt8MJHu/t2XtPI5EXTb+2Wolk76oXf4VtRIu/Ia0XLX/oKHWhdEPEyQqknBqGShWV3zoOOK/MOmBOHfqcTflw9qLUcekavv5q2XfUBfvICv8VN6HhJRB3oz/JvKvlrU3v2iAVSC9bjRJDBwunXcDpVLF57uISZ/84K4RHuQq5I8odjgS8Gmx0Q93AXVo84gSMegqngd2C
i6OwZGWEJ1G5xJEbi4Y4PgZB8SyUFHpH5RC5ktsnhKHtcM/Uaf+g7ZZvLOIAoaOfVwwtMr30Fqr1tjQreoXZx5GmzxsNLce+gAXH
tasks:
- internal.lock_machines:
- 2
- plana
- internal.save_config: null
- internal.check_lock: null
- internal.connect: null
- internal.check_conflict: null
- internal.check_ceph_data: null
- internal.vm_setup: null
- kernel: *id001
- internal.base: null
- internal.archive: null
- internal.coredump: null
- internal.sudo: null
- internal.syslog: null
- internal.timer: null
- chef: null
- clock.check: null
- install: null
- ceph:
log-whitelist:
- wrongly marked me down
- objects unfound and apparently lost
- thrashosds:
chance_pgnum_grow: 1
chance_pgpnum_fix: 1
chance_test_map_discontinuity: 0.5
timeout: 1200
- rados:
clients:
- client.0
objects: 500
op_weights:
delete: 50
read: 100
rollback: 50
snap_create: 50
snap_remove: 50
write: 100
ops: 4000
teuthology_branch: master
verbose: true

#2 Updated by Sage Weil about 6 years ago

ubuntu@teuthology:/a/teuthology-2013-09-28_23:00:19-rados-next-testing-basic-plana/23258 ?

#3 Updated by Samuel Just about 6 years ago

[note for bug scrub] Will need to reproduce in order to make progress. May not be urgent.

#4 Updated by Samuel Just about 6 years ago

  • Status changed from New to Need More Info

#5 Updated by Sage Weil about 6 years ago

ubuntu@teuthology:/a/teuthology-2013-10-15_18:01:09-rados-next-testing-basic-plana/53636

#6 Updated by Sage Weil about 6 years ago

  • Status changed from Need More Info to 12

#7 Updated by Greg Farnum about 6 years ago

  • Assignee set to Greg Farnum

Here goes nuttin', from what Sam says... ;)

#8 Updated by Greg Farnum about 6 years ago

  • Status changed from 12 to Duplicate
  • Parent task set to #6116

Looks like these are the same problem (which, luckily, users are seriously unlikely to come across).

Also available in: Atom PDF