Project

General

Profile

Bug #6279

creating a new fs on pools from an old fs can lead to lost MDS Tables

Added by Greg Farnum almost 6 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/11/2013
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
dumpling
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

See the thread at http://www.mail-archive.com/ceph-users@lists.ceph.com/msg03918.html

If you delete your FS (but not the data pools), then create a new FS on the same pools, the MDS client IDs are repeated. This means that if you haven't started recycling ops in the PG log, the OSDs will incorrectly return success on writes without doing anything. This can lead to eg not having a snaptable on disk, because the MDS tries to write out the initial one and the OSD says "I already have that tid, and the op succeeded" and short-circuits.

The best solution I've come up with so far is to somehow add an FS generation number to the MDS entity/invocation stuff, but I don't like having to maintain or steal that number in the Monitors...

Associated revisions

Revision 40613b70 (diff)
Added by Yan, Zheng almost 6 years ago

mon/MDSMonitor: don't reset incarnation when creating newfs

Fixes: #6279

Signed-off-by: Yan, Zheng <>

Revision bd073eea (diff)
Added by Yan, Zheng almost 6 years ago

mon/MDSMonitor: don't reset incarnation when creating newfs

Fixes: #6279

Signed-off-by: Yan, Zheng <>
(cherry picked from commit 40613b700b87b495d67793101ae05d6ba58b2a9a)
Reviewed-by: Greg Farnum <>

History

#1 Updated by Zheng Yan almost 6 years ago

  • Status changed from New to Verified

#2 Updated by Zheng Yan almost 6 years ago

  • Status changed from Verified to Need Review

#3 Updated by Greg Farnum almost 6 years ago

  • Status changed from Need Review to Resolved

Merged in commit:a41aa9468f4c8dd92604c20e015904ac75f1e746.

Thanks!

#4 Updated by Greg Farnum almost 6 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to dumpling

#5 Updated by Greg Farnum almost 6 years ago

  • Status changed from Pending Backport to Resolved

Oh, this is already backported, commit:bd073eeac28d8cba969e5746c5e6adcb95820fdf

#6 Updated by Greg Farnum about 3 years ago

  • Component(FS) MDS added

Also available in: Atom PDF