Project

General

Profile

Actions

Bug #62676

closed

cephfs-mirror: 'peer_bootstrap import' hangs

Added by Jos Collin 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Component(FS):
cephfs-mirror
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

'peer_bootstrap import' command hangs subsequent to using wrong/invalid token to import. If we use an invalid token in the 'peer_bootstrap import' command, then onwards the command hangs even if we provide a valid token to import. A cephfs-mirror daemon restart fixes this.

Actions #1

Updated by Jos Collin 7 months ago

  • Status changed from New to Closed

This is not a bug it seems. It waits for 5 minutes for the secrets to expire. Don't press Ctrl+C, Just wait for 5 minutes and the same 'peer_bootstrap import' command succeeds.

Actions #2

Updated by Milind Changire 7 months ago

If this is just a perception issue then a message to the user like "You need to wait for 5 minutes for this command to take effect", before the command is executed should resolve the confusion.

Actions

Also available in: Atom PDF