Project

General

Profile

Actions

Bug #62432

closed

Shaman build breaks on "docker tag ceph-ci/daemon-base"

Added by Yuri Weinstein 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Build started 2023-08-11

https://shaman.ceph.com/builds/ceph/main/c26ceafe90ae988e3dd10ffd9504e4c7c93d1f77/

https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVA[…]entos8,DIST=centos8,MACHINE_SIZE=gigantic/72002//consoleFull

cp: cannot stat '/etc/selinux/targeted/contexts/files/file_contexts': No such file or directory
Failed to resolve roletype statement at /var/lib/selinux/targeted/tmp/modules/400/ceph/cil:2
/usr/sbin/semodule:  Failed!

Related issues 1 (0 open1 closed)

Related to Infrastructure - Bug #62434: Reef builds failing from incorrect bash during docker installResolvedLaura Flores

Actions
Actions #1

Updated by Yuri Weinstein 8 months ago

It looks like a similar error is on the pacific build:

https://shaman.ceph.com/builds/ceph/wip-yuri8-testing-2023-08-11-0834-pacific/81efbc17688f2a6655111d1bf3cbcab8e36b5ff7/

https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=centos8,DIST=centos8,MACHINE_SIZE=gigantic/72008//consoleFull

Running scriptlet: ceph-selinux-2:16.2.13-468.g81efbc17.el8.x86_64    203/250 
cp: cannot stat '/etc/selinux/targeted/contexts/files/file_contexts': No such file or directory
Failed to resolve roletype statement at /var/lib/selinux/targeted/tmp/modules/400/ceph/cil:2
/usr/sbin/semodule:  Failed!
Actions #2

Updated by Laura Flores 8 months ago

Jenkins does a bad job of highlighting the true failure. The error message pasted above even occurs in successful builds.

This is the true failure:
https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=centos8,DIST=centos8,MACHINE_SIZE=gigantic/72002//consoleFull

Error: ceph-ci/daemon-base:main-c26ceaf-main-centos-stream8-x86_64: image not known

In the pacific build, it's the same thing:
https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=centos8,DIST=centos8,MACHINE_SIZE=gigantic/72008//consoleFull

Error: ceph-ci/daemon-base:wip-yuri8-testing-2023-08-11-0834-pacific-81efbc1-pacific-centos-stream8-x86_64: image not known

Actions #3

Updated by Laura Flores 8 months ago

Specifically, it's failing on "docker tag":

+ docker tag ceph-ci/daemon-base:main-c26ceaf-main-centos-stream8-x86_64 quay-quay-quay.apps.os.sepia.ceph.com/ceph-ci/ceph:main-c26ceaf-centos-stream8-x86_64-devel
Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.
Error: ceph-ci/daemon-base:main-c26ceaf-main-centos-stream8-x86_64: image not known

Here's the same action on a successful build:
https://jenkins.ceph.com/job/ceph-dev-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=centos8,DIST=centos8,MACHINE_SIZE=gigantic/53070//consoleFull

+ docker tag ceph-ci/daemon-base:main-141cb3d-main-centos-stream8-x86_64 quay.ceph.io/ceph-ci/ceph:main
Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.
+ docker tag ceph-ci/daemon-base:main-141cb3d-main-centos-stream8-x86_64 quay.ceph.io/ceph-ci/ceph:141cb3d1433b91c14fa3bc4aa89459e156cbe4e6
Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.
+ docker push quay.ceph.io/ceph-ci/ceph:main
Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.
Getting image source signatures
Copying blob sha256:b148aeabf3984c0345bd8253498ded5763a324a307cfa945e1bb8128d406f692
Copying blob sha256:54e8a1086febd852882fe51ef308b164c8ce39a640c4809af452468d8eb6ef50
Copying config sha256:be7ddc68621bdf0d9def5c3d9adaae5139a720829827c9c578ed6c0f993dec33
Writing manifest to image destination
Storing signatures
+ docker push quay.ceph.io/ceph-ci/ceph:141cb3d1433b91c14fa3bc4aa89459e156cbe4e6
Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.
Getting image source signatures
Copying blob sha256:b148aeabf3984c0345bd8253498ded5763a324a307cfa945e1bb8128d406f692
Copying blob sha256:54e8a1086febd852882fe51ef308b164c8ce39a640c4809af452468d8eb6ef50
Copying config sha256:be7ddc68621bdf0d9def5c3d9adaae5139a720829827c9c578ed6c0f993dec33
Writing manifest to image destination
Storing signatures

Actions #4

Updated by Laura Flores 8 months ago

  • Subject changed from main build is broken to Shaman build breaks on "docker tag ceph-ci/daemon-base"
Actions #5

Updated by Laura Flores 8 months ago

I think the local tag has potentially changed:

COMMIT ceph-ci/daemon-base:main-141cb3d-main-centos-stream8-x86_64

vs.

COMMIT ceph-ci/ceph/daemon-base:main-c26ceaf-main-centos-stream8-x86_64

Actions #6

Updated by Laura Flores 8 months ago

This looks like this commit (from 3 days ago) changed the local image name:
https://github.com/ceph/ceph-container/commit/15054d97b0fcf406542d9c1ea6cc6897f45ad732

Actions #7

Updated by Laura Flores 8 months ago

  • Regression changed from No to Yes
Actions #9

Updated by Laura Flores 8 months ago

  • Status changed from New to Fix Under Review
Actions #10

Updated by Laura Flores 8 months ago

  • Pull request ID set to 2144
Actions #11

Updated by Laura Flores 8 months ago

  • Pull request ID deleted (2144)
Actions #12

Updated by Laura Flores 8 months ago

  • Related to Bug #62434: Reef builds failing from incorrect bash during docker install added
Actions #13

Updated by Laura Flores 8 months ago

  • Status changed from Fix Under Review to Resolved
Actions

Also available in: Atom PDF