Project

General

Profile

Bug #61913

Bug #56698: client: FAILED ceph_assert(_size == 0)

client: crash the client more gracefully

Added by Xiubo Li 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Instead of crashing the client in xlist<T>::~xlist() it will be easier to understand exactly which xlist triggers this. And will be easier to debug the root cause.

More detail please see https://tracker.ceph.com/issues/56698.

History

#1 Updated by Xiubo Li 8 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 52335

#2 Updated by Xiubo Li 7 months ago

  • Status changed from Fix Under Review to Closed

Also available in: Atom PDF