Project

General

Profile

Actions

Bug #61533

closed

osd specs with 'spec' field but device selection outside of 'spec' field fail to apply

Added by Adam King 12 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
backport_processed
Backport:
reef, quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

currently a spec like

service_type: osd
service_id: foo
service_name: osd.foo
placement:
  host_pattern: '*'
spec:
  data_devices:
    paths:
    - /dev/vdc
    - /dev/vdd

and a spec like

service_type: osd
service_id: default_drive_group
placement:
  host_pattern: '*'
data_devices:
  all: true

work fine, but

service_type: osd
service_id: xxx
service_name: osd.xxx
placement:
  hosts:
  - vm-00
spec:
  osds_per_device: 2
data_devices:
  paths:
  - /dev/vde

fails with

Error EINVAL: ServiceSpec: 'dict' object has no attribute 'validate'

This is due to handling of the `spec` field along with special conversions of the device selection part of the spec (`data_devices` portion in the examples) that must be transformed into instances of the `DeviceSelection` class rather than just being a dict in order to validate the spec.


Related issues 3 (0 open3 closed)

Copied to Orchestrator - Backport #61684: reef: osd specs with 'spec' field but device selection outside of 'spec' field fail to applyResolvedAdam KingActions
Copied to Orchestrator - Backport #61685: quincy: osd specs with 'spec' field but device selection outside of 'spec' field fail to applyResolvedAdam KingActions
Copied to Orchestrator - Backport #61686: pacific: osd specs with 'spec' field but device selection outside of 'spec' field fail to applyResolvedAdam KingActions
Actions #1

Updated by Adam King 12 months ago

  • Pull request ID set to 51861
Actions #2

Updated by Adam King 11 months ago

  • Status changed from New to Pending Backport
Actions #3

Updated by Backport Bot 11 months ago

  • Copied to Backport #61684: reef: osd specs with 'spec' field but device selection outside of 'spec' field fail to apply added
Actions #4

Updated by Backport Bot 11 months ago

  • Copied to Backport #61685: quincy: osd specs with 'spec' field but device selection outside of 'spec' field fail to apply added
Actions #5

Updated by Backport Bot 11 months ago

  • Copied to Backport #61686: pacific: osd specs with 'spec' field but device selection outside of 'spec' field fail to apply added
Actions #6

Updated by Backport Bot 11 months ago

  • Tags set to backport_processed
Actions #7

Updated by Adam King 2 months ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF