Project

General

Profile

Bug #615

osd: improve op+journal throttling

Added by Sage Weil over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Currently we block first, then take locks, then update the throttle accounting. This makes things racy, because a bunch of threads could pile up, wait, and then all wake up once a small amount is available and get submitted. The result is bursty. But fixing it properly will be a bit tricky...

History

#1 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_story_points changed from 0 to 3
  • translation missing: en.field_position set to 1
  • translation missing: en.field_position changed from 1 to 562

#2 Updated by Sage Weil over 9 years ago

  • Status changed from New to Resolved
  • Target version changed from 12 to v0.26

#3 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_story_points changed from 3 to 2
  • translation missing: en.field_position deleted (586)
  • translation missing: en.field_position set to 576

Also available in: Atom PDF