Project

General

Profile

Bug #6105

HighDPI Support bug in gauge.js for Firefox

Added by Yan-Fa Li about 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

gauge.js has support for retina displays, something about the latest firefox is breaking it and causing it to render the image in high DPI mode instead of honoring the size requested which causes rendering errors.

History

#1 Updated by Yan-Fa Li about 8 years ago

Looks like this is a change in behavior for firefox

https://support.mozilla.org/en-US/questions/962990

#2 Updated by Yan-Fa Li about 8 years ago

OK, filed a bug in gauge.js. The work around I tried first by setting an option didn't seem to work so I monkey patched their CSS style changes after they do their initial render. Firefox sucks.

#3 Updated by Dan Mick over 7 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF