Project

General

Profile

Bug #6099

ceph-rest-api: default log file doesn't work because not daemon

Added by Dan Mick over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
rest-api
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
dumpling
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

ceph-rest-api assumes that it can either get the user's choice or the default log file from
rados_conf_get("log_file"). However, the default for non-daemons is not "/var/log/ceph/$cluster-$name.log",
but rather "", by design.

The easy fix is to make ceph-rest-api set its own default.

Associated revisions

Revision 2031f391 (diff)
Added by Dan Mick over 7 years ago

ceph_rest_api.py: create own default for log_file

common/config thinks the default log_file for non-daemons should be "".
Override that so that the default is
/var/log/ceph/{cluster}-{name}.{pid}.log
since ceph-rest-api is more of a daemon than a client.

Fixes: #6099
Backport: dumpling
Signed-off-by: Dan Mick <>

Revision 83cfd438 (diff)
Added by Dan Mick over 7 years ago

ceph_rest_api.py: create own default for log_file

common/config thinks the default log_file for non-daemons should be "".
Override that so that the default is
/var/log/ceph/{cluster}-{name}.{pid}.log
since ceph-rest-api is more of a daemon than a client.

Fixes: #6099
Backport: dumpling
Signed-off-by: Dan Mick <>
(cherry picked from commit 2031f391c3df68e0d9e381a1ef3fe58d8939f0a8)

History

#1 Updated by Dan Mick over 7 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Dan Mick over 7 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF