Project

General

Profile

Bug #58949

qa: test_cephfs.test_disk_quota_exceeeded_error is racy

Added by Rishabh Dave 12 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

test_cephfs.test_disk_quota_exceeeded_error's failure has been reported here before - https://tracker.ceph.com/issues/58220#note-9.

The failing job was run by me very recently - http://pulpito.front.sepia.ceph.com/rishabh-2023-03-03_21:39:49-fs-wip-rishabh-2023Mar03-2316-testing-default-smithi/7193845. At the same time, Venky did not see this job fail in his QA run - http://ceph/teuthology-archive/vshankar-2023-03-08_15:12:36-fs-wip-vshankar-testing-20230308.112059-testing-default-smithi/7197038/

Thus, this test is racy. Let's add a small pause in execution after quota attribute is applied on cephfs directory, so that this race won't happen and test results are consistent.

History

#1 Updated by Rishabh Dave 12 months ago

  • Subject changed from tests: test_cephfs.test_disk_quota_exceeeded_error is racy to qa: test_cephfs.test_disk_quota_exceeeded_error is racy
  • Description updated (diff)

#2 Updated by Rishabh Dave 12 months ago

  • Description updated (diff)

#3 Updated by Rishabh Dave 12 months ago

Venky, this most likely is not race condition. Your testing branch had patch that fixes quota issue. See - https://github.com/ceph/ceph-ci/commit/901da0678a13417bdc10a3888aaa1d85adeac2f2

#4 Updated by Greg Farnum 11 months ago

  • Status changed from New to Rejected

Closing per previous comment.

#6 Updated by Kotresh Hiremath Ravishankar 10 months ago

  • Status changed from Rejected to Need More Info

#7 Updated by Rishabh Dave 9 months ago

Hi Kotresh. This ticket was closed because the failure described in this ticket was not due to a bug but due to some issue in a couple of testing branches. If this job is failing now, IMO, the cause can't be the same. Therefore, opening a different tracker ticket is more appropriate thing to do IMO.

#8 Updated by Kotresh Hiremath Ravishankar 9 months ago

  • Status changed from Need More Info to Rejected

Hi Rishabh,

You are right. There was already a ticket (https://tracker.ceph.com/issues/59346) by Xiubo. I will close this.

Thanks,
Kotresh H R

Also available in: Atom PDF