Project

General

Profile

Actions

Bug #58303

closed

active mgr crashes with segfault when running 'ceph osd purge'

Added by Christian Theune over 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
% Done:

100%

Source:
Community (user)
Tags:
backport_processed
Backport:
pacific quincy reef
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

I initially reported this for Nautilus, however, I'm not sure what the current policy about "gardening" issues for old releases is. I wrote a note in the other ticket that looking at the code this issue is still present on the main branch.

As I can't edit my old ticket I'm adding this for good measure (without the intent to spam) with 18.0 as the affected version.

Please check details in https://tracker.ceph.com/issues/58215 and feel free to consider this a duplicate and change the "affected version" in the other issue.

I also added an updated PR for main.


Related issues 5 (0 open5 closed)

Has duplicate Ceph - Bug #58215: active mgr crashes with segfault when running 'ceph osd purge'Duplicate

Actions
Is duplicate of RADOS - Bug #61912: mgr hang when purging OSDsDuplicatedongdong tao

Actions
Copied to Ceph - Backport #62091: pacific: active mgr crashes with segfault when running 'ceph osd purge'ResolvedKonstantin ShalyginActions
Copied to Ceph - Backport #62092: quincy: active mgr crashes with segfault when running 'ceph osd purge'ResolvedKonstantin ShalyginActions
Copied to Ceph - Backport #62093: reef: active mgr crashes with segfault when running 'ceph osd purge'ResolvedKonstantin ShalyginActions
Actions #1

Updated by Radoslaw Zarzynski 9 months ago

  • Has duplicate Bug #58215: active mgr crashes with segfault when running 'ceph osd purge' added
Actions #2

Updated by Radoslaw Zarzynski 9 months ago

  • Status changed from New to Fix Under Review
Actions #3

Updated by Matan Breizman 9 months ago

  • Is duplicate of Bug #61912: mgr hang when purging OSDs added
Actions #4

Updated by Matan Breizman 9 months ago

  • Backport set to reef, quincy
Actions #5

Updated by Matan Breizman 9 months ago

  • Status changed from Fix Under Review to Duplicate
Actions #6

Updated by Matan Breizman 9 months ago

  • Status changed from Duplicate to Fix Under Review
Actions #7

Updated by Konstantin Shalygin 9 months ago

  • Assignee set to Christian Theune
  • Target version set to v19.0.0
  • Backport changed from reef, quincy to pacific quincy reef
Actions #8

Updated by Konstantin Shalygin 9 months ago

  • Status changed from Fix Under Review to Pending Backport
Actions #9

Updated by Backport Bot 9 months ago

  • Copied to Backport #62091: pacific: active mgr crashes with segfault when running 'ceph osd purge' added
Actions #10

Updated by Backport Bot 9 months ago

  • Copied to Backport #62092: quincy: active mgr crashes with segfault when running 'ceph osd purge' added
Actions #11

Updated by Backport Bot 9 months ago

  • Copied to Backport #62093: reef: active mgr crashes with segfault when running 'ceph osd purge' added
Actions #12

Updated by Backport Bot 9 months ago

  • Tags set to backport_processed
Actions #13

Updated by Konstantin Shalygin 4 months ago

  • Status changed from Pending Backport to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF