Project

General

Profile

Bug #58097

qa/workunits/post-file.sh: kex_exchange_identification: read: Connection reset by peer

Added by Laura Flores 2 months ago. Updated 6 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

/a/yuriw-2022-11-23_15:09:06-rados-wip-yuri10-testing-2022-11-22-1711-distro-default-smithi/7087430

2022-11-23T22:56:12.649 DEBUG:teuthology.orchestra.run.smithi167:workunit test post-file.sh> mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=ac01e2c21e15a00b6baca53640db7f447512f3ce TESTDIR="/home/ubuntu/cephtest" CEPH_ARGS="--cluster ceph" CEPH_ID="0" PATH=$PATH:/usr/sbin CEPH_BASE=/home/ubuntu/cephtest/clone.client.0 CEPH_ROOT=/home/ubuntu/cephtest/clone.client.0 CEPH_MNT=/home/ubuntu/cephtest/mnt.0 adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 3h /home/ubuntu/cephtest/clone.client.0/qa/workunits/post-file.sh
2022-11-23T22:56:12.721 INFO:tasks.workunit.client.0.smithi167.stderr:+ what=
2022-11-23T22:56:12.722 INFO:tasks.workunit.client.0.smithi167.stderr:+ '[' -z '' ']'
2022-11-23T22:56:12.722 INFO:tasks.workunit.client.0.smithi167.stderr:+ what=/etc/udev/rules.d
2022-11-23T22:56:12.722 INFO:tasks.workunit.client.0.smithi167.stderr:+ sudo ceph-post-file -d ceph-test-workunit /etc/udev/rules.d
2022-11-23T22:56:12.734 INFO:tasks.workunit.client.0.smithi167.stdout:args: -d ceph-test-workunit -- /etc/udev/rules.d
2022-11-23T22:56:12.734 INFO:tasks.workunit.client.0.smithi167.stdout:args: -- /etc/udev/rules.d
2022-11-23T22:56:12.741 INFO:tasks.workunit.client.0.smithi167.stdout:/bin/ceph-post-file: upload tag d2808a8a-47c9-4333-b7ae-3c8f14797482
2022-11-23T22:56:12.745 INFO:tasks.workunit.client.0.smithi167.stdout:/bin/ceph-post-file: user: root@smithi167
2022-11-23T22:56:12.746 INFO:tasks.workunit.client.0.smithi167.stdout:/bin/ceph-post-file: description: ceph-test-workunit
2022-11-23T22:56:12.747 INFO:tasks.workunit.client.0.smithi167.stdout:/bin/ceph-post-file: will upload directory /etc/udev/rules.d
2022-11-23T22:56:17.770 INFO:tasks.workunit.client.0.smithi167.stderr:kex_exchange_identification: read: Connection reset by peer
2022-11-23T22:56:17.771 INFO:tasks.workunit.client.0.smithi167.stderr:^MConnection closed.
2022-11-23T22:56:17.771 INFO:tasks.workunit.client.0.smithi167.stderr:Connection closed
2022-11-23T22:56:17.774 DEBUG:teuthology.orchestra.run:got remote process result: 255
2022-11-23T22:56:17.774 INFO:tasks.workunit:Stopping ['post-file.sh'] on client.0...


Related issues

Related to Ceph - Bug #58458: qa/workunits/post-file.sh: postfile@drop.ceph.com: Permission denied Duplicate

History

#1 Updated by Laura Flores 2 months ago

  • Subject changed from qa/workunits/post-file.sh: Connection reset by peer to qa/workunits/post-file.sh: kex_exchange_identification: read: Connection reset by peer

Reproducible locally:

[lflores@folio01 build]$ ./bin/ceph-post-file -d laura-test test.txt
args: -d laura-test -- test.txt
args: -- test.txt
./bin/ceph-post-file: upload tag 2da53ec6-db82-4e16-ac19-4a6274e94c84
./bin/ceph-post-file: user: lflores@folio01.front.sepia.ceph.com
./bin/ceph-post-file: description: laura-test
./bin/ceph-post-file: will upload file test.txt
/tmp/tmp.DLFRJWEVnV ../share/known_hosts_drop.ceph.com /tmp/tmp.DVSUhPFL3V postfile@drop.ceph.com
kex_exchange_identification: read: Connection reset by peer
Connection closed.  
Connection closed

[lflores@folio01 build]$ ssh postfile@drop.ceph.com
kex_exchange_identification: read: Connection reset by peer

Seems to be an issue with .

#2 Updated by Laura Flores 2 months ago

  • Project changed from Ceph to Infrastructure
  • Assignee set to Dan Mick

A note from Dan Mick: "drop.ceph.com" is another corrupted VM that needs rebuilding.

Dan, I'm assigning the tracker to you so it's on your radar, but please let me know if I can assist in any way.

#3 Updated by Matan Breizman 2 months ago

Related to drop.ceph.com:

2022-11-30T12:43:08.924 INFO:tasks.workunit.client.0.smithi038.stdout:/bin/ceph-post-file: description: ceph-test-workunit
2022-11-30T12:43:08.925 INFO:tasks.workunit.client.0.smithi038.stdout:/bin/ceph-post-file: will upload directory /etc/udev/rules.d
2022-11-30T12:45:19.224 INFO:tasks.workunit.client.0.smithi038.stderr:ssh: connect to host drop.ceph.com port 22: Connection timed out

/a/yuriw-2022-11-28_16:28:53-rados-wip-yuri-testing-2022-11-18-1500-pacific-distro-default-smithi/7094340/

/a/yuriw-2022-11-28_21:13:47-rados-wip-yuri11-testing-2022-11-18-1506-distro-default-smithi/7095066/
/a/yuriw-2022-11-28_21:13:47-rados-wip-yuri11-testing-2022-11-18-1506-distro-default-smithi/7095029/

#4 Updated by Kamoltat (Junior) Sirivadhna about 1 month ago

/a/ksirivad-2022-12-21_15:23:02-rados-wip-ksirivad-test-quincy-distro-default-smithi/7123747

#5 Updated by Kamoltat (Junior) Sirivadhna about 1 month ago

/a/ksirivad-2022-12-22_17:58:01-rados-wip-ksirivad-testing-pacific-distro-default-smithi/7124885/

#6 Updated by Laura Flores 17 days ago

  • Related to Bug #58458: qa/workunits/post-file.sh: postfile@drop.ceph.com: Permission denied added

#7 Updated by Dan Mick 6 days ago

  • Status changed from New to Resolved

This is fixed for now; the postfile sftp account is up on drop.ceph.com. At the moment, the files are not stored on the LRC as they have been in the past; I'm debating about the wisdom of that. But files will be put on the gw server in /sftp/postfile/post for now.

I note that the ceph-drop-file test uploads a file and then leaves it forever, which is probably not the best behavior. We should probably add a "cleanup" phase to that shell script.

Also available in: Atom PDF