Project

General

Profile

Bug #57754

test_envlibrados_for_rocksdb.sh: update-alternatives: error: alternative path /usr/bin/gcc-11 doesn't exist

Added by Laura Flores 4 months ago. Updated 14 days ago.

Status:
Closed
Priority:
Normal
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

/a/yuriw-2022-09-29_16:44:24-rados-wip-lflores-testing-distro-default-smithi/7048086

2022-09-29T22:08:51.589 INFO:tasks.workunit.client.0.smithi124.stdout:Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
2022-09-29T22:08:52.005 INFO:tasks.workunit.client.0.smithi124.stderr:++ distro_id
2022-09-29T22:08:52.006 INFO:tasks.workunit.client.0.smithi124.stderr:++ source /etc/os-release
2022-09-29T22:08:52.006 INFO:tasks.workunit.client.0.smithi124.stderr:+++ NAME=Ubuntu
2022-09-29T22:08:52.006 INFO:tasks.workunit.client.0.smithi124.stderr:+++ VERSION='20.04.5 LTS (Focal Fossa)'
2022-09-29T22:08:52.007 INFO:tasks.workunit.client.0.smithi124.stderr:+++ ID=ubuntu
2022-09-29T22:08:52.007 INFO:tasks.workunit.client.0.smithi124.stderr:+++ ID_LIKE=debian
2022-09-29T22:08:52.007 INFO:tasks.workunit.client.0.smithi124.stderr:+++ PRETTY_NAME='Ubuntu 20.04.5 LTS'
2022-09-29T22:08:52.007 INFO:tasks.workunit.client.0.smithi124.stderr:+++ VERSION_ID=20.04
2022-09-29T22:08:52.008 INFO:tasks.workunit.client.0.smithi124.stderr:+++ HOME_URL=https://www.ubuntu.com/
2022-09-29T22:08:52.008 INFO:tasks.workunit.client.0.smithi124.stderr:+++ SUPPORT_URL=https://help.ubuntu.com/
2022-09-29T22:08:52.008 INFO:tasks.workunit.client.0.smithi124.stderr:+++ BUG_REPORT_URL=https://bugs.launchpad.net/ubuntu/
2022-09-29T22:08:52.008 INFO:tasks.workunit.client.0.smithi124.stderr:+++ PRIVACY_POLICY_URL=https://www.ubuntu.com/legal/terms-and-policies/privacy-policy
2022-09-29T22:08:52.008 INFO:tasks.workunit.client.0.smithi124.stderr:+++ VERSION_CODENAME=focal
2022-09-29T22:08:52.009 INFO:tasks.workunit.client.0.smithi124.stderr:+++ UBUNTU_CODENAME=focal
2022-09-29T22:08:52.009 INFO:tasks.workunit.client.0.smithi124.stderr:++ echo ubuntu
2022-09-29T22:08:52.009 INFO:tasks.workunit.client.0.smithi124.stderr:+ '[' ubuntu = ubuntu ']'
2022-09-29T22:08:52.009 INFO:tasks.workunit.client.0.smithi124.stderr:+ sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-11 11
2022-09-29T22:08:52.015 INFO:tasks.workunit.client.0.smithi124.stderr:update-alternatives: error: alternative path /usr/bin/gcc-11 doesn't exist
2022-09-29T22:08:52.017 DEBUG:teuthology.orchestra.run:got remote process result: 2
2022-09-29T22:08:52.018 INFO:tasks.workunit:Stopping ['rados/test_envlibrados_for_rocksdb.sh'] on client.0...
2022-09-29T22:08:52.019 DEBUG:teuthology.orchestra.run.smithi124:> sudo rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0


Related issues

Related to RADOS - Bug #57632: test_envlibrados_for_rocksdb: free(): invalid pointer Closed

History

#1 Updated by Radoslaw Zarzynski 4 months ago

  • Project changed from RADOS to Infrastructure

No GCC11 installed?

#2 Updated by adam kraitman 4 months ago

  • Status changed from New to In Progress
  • Assignee set to adam kraitman

#3 Updated by Laura Flores 3 months ago

/a/yuriw-2022-10-19_18:35:19-rados-wip-yuri10-testing-2022-10-19-0810-distro-default-smithi/7074826

#4 Updated by Laura Flores 3 months ago

  • Related to Bug #57632: test_envlibrados_for_rocksdb: free(): invalid pointer added

#5 Updated by Matan Breizman 3 months ago

  • Assignee changed from adam kraitman to Matan Breizman
This failure is caused by https://github.com/ceph/ceph/pull/47900 changes.
The only 2 tests to use `ceph-helpers-root.sh` are
  • test_librados_build.sh
  • test_envlibrados_for_rocksdb.sh

`test_librados_build` failure was fixed by installing g++11 and compiling with c++20 to avoid version mismatch and passing the test. (PR mentioned above)

`test_envlibrados_for_rocksdb` will also be compiled with newer g++/c++ versions since we were hitting a similar error.
The tracker with the suggested changes PR is: https://tracker.ceph.com/issues/57632.

However, applying these changes still didn't resolve the "invalid pointer" failure. Hence it is not merged yet.
Once 57632 will be resolved this tracker (57754) will also resolve.

#6 Updated by Laura Flores 14 days ago

  • Status changed from In Progress to Closed

"Closed" since we merged a workaround rather than a fix.

Also available in: Atom PDF