Project

General

Profile

Actions

Bug #57727

closed

mon_cluster_log_file_level option doesn't take effect

Added by Ilya Dryomov over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This appears to be regression introduced in quincy in https://github.com/ceph/ceph/pull/42014:

-      if (g_conf()->mon_cluster_log_to_file) {
-       string log_file = channels.get_log_file(channel);
-       dout(20) << __func__ << " logging for channel '" << channel
-                << "' to file '" << log_file << "'" << dendl;
-
-       if (!log_file.empty()) {
-         string log_file_level = channels.get_log_file_level(channel);
-         if (log_file_level.empty()) {
-           dout(1) << __func__ << " warning: log file level not defined for" 
-                   << " channel '" << channel << "' yet a log file is --" 
-                   << " will assume lowest level possible" << dendl;
-         }
-
-         int min = string_to_syslog_level(log_file_level);
-         int l = clog_type_to_syslog_level(le.prio);
-         if (l <= min) {

get_log_file_level() just isn't called anymore.


Related issues 1 (0 open1 closed)

Is duplicate of RADOS - Bug #57049: cluster logging does not adhere to mon_cluster_log_file_levelDuplicatePrashant D

Actions
Actions #1

Updated by Prashant D over 1 year ago

Hi Ilya,

I had a PR#47480 opened for this issue but closed it in favor of PR#47502. We have a old tracker 57049 for this issue. Closing this tracker as a duplicate of 57049.

Actions #2

Updated by Ilya Dryomov over 1 year ago

  • Status changed from New to Fix Under Review
  • Assignee set to Prashant D
  • Pull request ID set to 47502
Actions #3

Updated by Ilya Dryomov over 1 year ago

  • Status changed from Fix Under Review to Duplicate
  • Pull request ID deleted (47502)

Ah, you edited your comment to say "Closing this tracker as a duplicate of 57049".

Actions #4

Updated by Ilya Dryomov over 1 year ago

  • Is duplicate of Bug #57049: cluster logging does not adhere to mon_cluster_log_file_level added
Actions #5

Updated by Prashant D over 1 year ago

Yes. I was trying to close it as a duplicate after editing my comment. Thank you for closing it.

Actions

Also available in: Atom PDF