Project

General

Profile

Bug #57321

xfstests: ceph/004 setfattr: /mnt/kcephfs.A/test-004/dest: Invalid argument

Added by Xiubo Li 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

[root@lxbceph1 xfstests-dev]# ./check ceph/004
FSTYP -- ceph
PLATFORM -- Linux/x86_64 lxbceph1 6.0.0-rc1+ #160 SMP PREEMPT_DYNAMIC Tue Aug 16 10:29:44 CST 2022
MKFS_OPTIONS -- 10.72.47.117:40653:/testB
MOUNT_OPTIONS -- -o name=admin,nowsync,copyfrom,rasize=4096 -o context=system_u:object_r:root_t:s0 10.72.47.117:40653:/testB /mnt/kcephfs.B

ceph/004 76s ... [failed, exit status 1]
- output mismatch (see /data/xfstests-dev/results//ceph/004.out.bad)
--- tests/ceph/004.out 2022-04-07 21:42:09.218992002 0800
+
+ /data/xfstests-dev/results//ceph/004.out.bad 2022-08-29 13:07:50.839836283 +0800
@ -1,2 +1,4 @
QA output created by 004
-Silence is golden
+setfattr: /mnt/kcephfs.A/test-004/dest: Invalid argument
+cross quota realms1 rename succeeded
+(see /data/xfstests-dev/results//ceph/004.full for details)
...
(Run 'diff -u /data/xfstests-dev/tests/ceph/004.out /data/xfstests-dev/results//ceph/004.out.bad' to see the entire diff)
Ran: ceph/004
Failures: ceph/004
Failed 1 of 1 tests

History

#1 Updated by Xiubo Li 5 months ago

It was caused by https://tracker.ceph.com/issues/56397. And I have sent one patch to fix it in xfstests repo.

#2 Updated by Xiubo Li 5 months ago

  • Status changed from New to Fix Under Review

#3 Updated by Xiubo Li 3 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF