Project

General

Profile

Bug #57227

run-rbd-unit-tests failing on make check

Added by Laura Flores 6 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
High
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Make check failures:
https://jenkins.ceph.com/job/ceph-pull-requests/102079/ (from https://github.com/ceph/ceph/pull/46723)

273/282 Test  #34: run-rbd-unit-tests-127.sh .................***Failed  408.79 sec
++ dirname /home/jenkins-build/build/workspace/ceph-pull-requests/src/test/run-rbd-unit-tests.sh
+ source /home/jenkins-build/build/workspace/ceph-pull-requests/src/test/detect-build-env-vars.sh
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build/bin ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib ']'
++ echo 'Enivronment Variables Already Set'
Enivronment Variables Already Set
+ PATH=/home/jenkins-build/build/workspace/ceph-pull-requests/build/bin:/home/jenkins-build/build/workspace/ceph-pull-requests/build/bin:/home/jenkins-build/build/workspace/ceph-pull-requests/src:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
+ '[' 1 = 0 ']'
+ '[' 1 = 1 -a 127 = N ']'
+ TESTS=127
+ for i in ${TESTS}
+ RBD_FEATURES=127
+ unittest_librbd
seed 3555546
[==========] Running 1219 tests from 108 test suites.
[----------] Global test environment set-up.
[----------] 2 tests from TestIOBlockGuard
[ RUN      ] TestIOBlockGuard.NonDetainedOps
Failed to load class: cas (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cas.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cas.so: undefined symbol: _Z26cls_get_manifest_ref_countPvNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE
Failed to load class: cmpomap (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cmpomap.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cmpomap.so: undefined symbol: _Z28cls_cxx_map_get_vals_by_keysPvRKSt3setINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEESt4lessIS6_ESaIS6_EEPSt3mapIS6_N4ceph6buffer7v15_2_04listES8_SaISt4pairIKS6_SH_EEE
Failed to load class: fifo (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_fifo.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_fifo.so: undefined symbol: _Z20cls_gen_random_bytesPci
Failed to load class: log (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_log.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_log.so: undefined symbol: _Z24cls_cxx_map_write_headerPvPN4ceph6buffer7v15_2_04listE
Failed to load class: rgw (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_rgw.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_rgw.so: undefined symbol: _Z19cls_get_object_infoPv
Failed to load class: user (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_user.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_user.so: undefined symbol: _Z24cls_cxx_map_write_headerPvPN4ceph6buffer7v15_2_04listE
[ RUN      ] TestMockMigrationHttpClient.OpenCloseHttp
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenCloseHttp (72 ms)
[ RUN      ] TestMockMigrationHttpClient.OpenCloseHttps
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenCloseHttps (77 ms)
[ RUN      ] TestMockMigrationHttpClient.OpenHttpsHandshakeFail
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenHttpsHandshakeFail (67 ms)
[ RUN      ] TestMockMigrationHttpClient.OpenInvalidUrl
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenInvalidUrl (66 ms)
[ RUN      ] TestMockMigrationHttpClient.OpenResolveFail
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenResolveFail (84 ms)
[ RUN      ] TestMockMigrationHttpClient.OpenConnectFail
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenConnectFail (77 ms)
[ RUN      ] TestMockMigrationHttpClient.IssueHead
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssueHead (76 ms)
[ RUN      ] TestMockMigrationHttpClient.IssueGet
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssueGet (68 ms)
[ RUN      ] TestMockMigrationHttpClient.IssueSendFailed
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssueSendFailed (73 ms)
[ RUN      ] TestMockMigrationHttpClient.IssueReceiveFailed
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssueReceiveFailed (73 ms)
[ RUN      ] TestMockMigrationHttpClient.IssueResetFailed
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssueResetFailed (78 ms)
[ RUN      ] TestMockMigrationHttpClient.IssuePipelined
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssuePipelined (66 ms)
[ RUN      ] TestMockMigrationHttpClient.IssuePipelinedRestart
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.IssuePipelinedRestart (59 ms)
[ RUN      ] TestMockMigrationHttpClient.ShutdownInFlight
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.ShutdownInFlight (62 ms)
[ RUN      ] TestMockMigrationHttpClient.GetSize
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.GetSize (54 ms)
[ RUN      ] TestMockMigrationHttpClient.GetSizeError
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.GetSizeError (59 ms)
[ RUN      ] TestMockMigrationHttpClient.Read
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.Read (63 ms)
[----------] 17 tests from TestMockMigrationHttpClient (1176 ms total)
282/282 Test  #33: run-rbd-unit-tests-109.sh .................***Timeout 3600.10 sec
++ dirname /home/jenkins-build/build/workspace/ceph-pull-requests/src/test/run-rbd-unit-tests.sh
+ source /home/jenkins-build/build/workspace/ceph-pull-requests/src/test/detect-build-env-vars.sh
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build/bin ']'
++ '[' -n /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib ']'
++ echo 'Enivronment Variables Already Set'
Enivronment Variables Already Set
+ PATH=/home/jenkins-build/build/workspace/ceph-pull-requests/build/bin:/home/jenkins-build/build/workspace/ceph-pull-requests/build/bin:/home/jenkins-build/build/workspace/ceph-pull-requests/src:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
+ '[' 1 = 0 ']'
+ '[' 1 = 1 -a 109 = N ']'
+ TESTS=109
+ for i in ${TESTS}
+ RBD_FEATURES=109
+ unittest_librbd
seed 3555544
[==========] Running 1219 tests from 108 test suites.
[----------] Global test environment set-up.
[----------] 2 tests from TestIOBlockGuard
[ RUN      ] TestIOBlockGuard.NonDetainedOps
Failed to load class: cas (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cas.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cas.so: undefined symbol: _Z26cls_get_manifest_ref_countPvNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE
Failed to load class: cmpomap (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cmpomap.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_cmpomap.so: undefined symbol: _Z28cls_cxx_map_get_vals_by_keysPvRKSt3setINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEESt4lessIS6_ESaIS6_EEPSt3mapIS6_N4ceph6buffer7v15_2_04listES8_SaISt4pairIKS6_SH_EEE
Failed to load class: fifo (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_fifo.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_fifo.so: undefined symbol: _Z20cls_gen_random_bytesPci
Failed to load class: log (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_log.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_log.so: undefined symbol: _Z24cls_cxx_map_write_headerPvPN4ceph6buffer7v15_2_04listE
Failed to load class: rgw (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_rgw.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_rgw.so: undefined symbol: _Z19cls_get_object_infoPv
Failed to load class: user (/home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_user.so): /home/jenkins-build/build/workspace/ceph-pull-requests/build/lib/libcls_user.so: undefined symbol: _Z24cls_cxx_map_write_headerPvPN4ceph6buffer7v15_2_04listE

jenkins_pr_47826.log.gz (278 KB) Yaarit Hatuka, 09/02/2022 04:48 PM


Related issues

Duplicates Ceph - Bug #57116: TestMockMigrationHttpClient and HTTPManager "bind: Address already in use [system:98]" failures Resolved

History

#1 Updated by Laura Flores 6 months ago

The timeout one looks like a dupe of https://tracker.ceph.com/issues/54292.

#3 Updated by Laura Flores 6 months ago

This bit

[ RUN      ] TestMockMigrationHttpClient.OpenCloseHttp
unknown file: Failure
C++ exception with description "bind: Address already in use [system:98]" thrown in SetUp().
[  FAILED  ] TestMockMigrationHttpClient.OpenCloseHttp (72 ms)

seems to be coming from this area of the code:

src/test/librbd/migration/test_mock_HttpClient.cc

  void SetUp() override {
    TestMockFixture::SetUp();

    ASSERT_EQ(0, open_image(m_image_name, &m_image_ctx));

    create_acceptor(false);
  }

#4 Updated by Laura Flores 6 months ago

  • Tags set to test_failure

#5 Updated by Laura Flores 6 months ago

  • Tags changed from test_failure to test-failure

#6 Updated by Laura Flores 6 months ago

  • Tags set to test-failure

#7 Updated by Laura Flores 6 months ago

  • Tags deleted (test-failure)

#8 Updated by Laura Flores 5 months ago

  • Assignee set to Christopher Hoffman

Hey Chris, I remember you were working on this issue, so I'm assigning it to you. But feel free to remove or update.

#10 Updated by Ronen Friedman 5 months ago

I would suggest giving this a higher priority, as it causes the CI to fail PRs.

https://jenkins.ceph.com/job/ceph-pull-requests/102501/testReport/junit/projectroot.src/test/run_rbd_unit_tests_0_sh/

#11 Updated by Laura Flores 5 months ago

  • Priority changed from Normal to High

#12 Updated by Christopher Hoffman 5 months ago

  • Duplicated by Bug #57116: TestMockMigrationHttpClient and HTTPManager "bind: Address already in use [system:98]" failures added

#13 Updated by Christopher Hoffman 5 months ago

  • Status changed from New to Duplicate

#14 Updated by Ilya Dryomov 5 months ago

  • Duplicated by deleted (Bug #57116: TestMockMigrationHttpClient and HTTPManager "bind: Address already in use [system:98]" failures)

#15 Updated by Ilya Dryomov 5 months ago

  • Duplicates Bug #57116: TestMockMigrationHttpClient and HTTPManager "bind: Address already in use [system:98]" failures added

#16 Updated by Yaarit Hatuka 5 months ago

Seeing similar make check failures on https://github.com/ceph/ceph/pull/47826 (a Quincy run). Log attached.

Also available in: Atom PDF