Project

General

Profile

Bug #56847

crash: void PaxosService::propose_pending(): assert(have_pending)

Added by Telemetry Bot over 1 year ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Telemetry
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):

2a49c9b59b3e73eb6df3eba6255b5f987b3b2a5263919468c35e65a5fe30eed6


Description

http://telemetry.front.sepia.ceph.com:4000/d/jByk5HaMz/crash-spec-x-ray?orgId=1&var-sig_v2=7a53cbc0bcdeffa2f26d71d0108e5f5ff3996898e40f82dacac9edba5a79a496

Assert condition: have_pending
Assert function: void PaxosService::propose_pending()

Sanitized backtrace:

    PaxosService::propose_pending()
    KVMonitor::do_osd_destroy(int, uuid_d&)
    OSDMonitor::prepare_command_osd_destroy(int, std::basic_stringstream<char, std::char_traits<char>, std::allocator<char> >&)
    OSDMonitor::prepare_command_osd_purge(int, std::basic_stringstream<char, std::char_traits<char>, std::allocator<char> >&)
    OSDMonitor::prepare_command_impl(boost::intrusive_ptr<MonOpRequest>, std::map<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, boost::variant<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, bool, long, double, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::vector<long, std::allocator<long> >, std::vector<double, std::allocator<double> > >, std::less<void>, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, boost::variant<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, bool, long, double, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::vector<long, std::allocator<long> >, std::vector<double, std::allocator<double> > > > > > const&)
    OSDMonitor::prepare_command(boost::intrusive_ptr<MonOpRequest>)
    OSDMonitor::prepare_update(boost::intrusive_ptr<MonOpRequest>)
    PaxosService::dispatch(boost::intrusive_ptr<MonOpRequest>)
    Monitor::handle_command(boost::intrusive_ptr<MonOpRequest>)
    Monitor::dispatch_op(boost::intrusive_ptr<MonOpRequest>)
    Monitor::_ms_dispatch(Message*)
    Monitor::handle_forward(boost::intrusive_ptr<MonOpRequest>)
    Monitor::dispatch_op(boost::intrusive_ptr<MonOpRequest>)
    Monitor::_ms_dispatch(Message*)
    Dispatcher::ms_dispatch2(boost::intrusive_ptr<Message> const&)
    DispatchQueue::entry()
    DispatchQueue::DispatchThread::entry()

Crash dump sample:
{
    "archived": "2022-07-08 00:30:59.353955",
    "assert_condition": "have_pending",
    "assert_file": "mon/PaxosService.cc",
    "assert_func": "void PaxosService::propose_pending()",
    "assert_line": 193,
    "assert_msg": "mon/PaxosService.cc: In function 'void PaxosService::propose_pending()' thread 7f0aa738d700 time 2022-07-08T00:18:18.803439+0000\nmon/PaxosService.cc: 193: FAILED ceph_assert(have_pending)",
    "assert_thread_name": "ms_dispatch",
    "backtrace": [
        "/lib64/libpthread.so.0(+0x12ce0) [0x7f0ab17eace0]",
        "gsignal()",
        "abort()",
        "(ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x1b0) [0x7f0ab3858c32]",
        "/usr/lib64/ceph/libceph-common.so.2(+0x283df5) [0x7f0ab3858df5]",
        "(PaxosService::propose_pending()+0x50d) [0x55718145908d]",
        "(KVMonitor::do_osd_destroy(int, uuid_d&)+0x3d9) [0x5571813f9af9]",
        "(OSDMonitor::prepare_command_osd_destroy(int, std::__cxx11::basic_stringstream<char, std::char_traits<char>, std::allocator<char> >&)+0x40e) [0x5571814a76be]",
        "(OSDMonitor::prepare_command_osd_purge(int, std::__cxx11::basic_stringstream<char, std::char_traits<char>, std::allocator<char> >&)+0x1b0) [0x5571814a79e0]",
        "(OSDMonitor::prepare_command_impl(boost::intrusive_ptr<MonOpRequest>, std::map<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, boost::variant<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, bool, long, double, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::vector<long, std::allocator<long> >, std::vector<double, std::allocator<double> > >, std::less<void>, std::allocator<std::pair<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const, boost::variant<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, bool, long, double, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, std::vector<long, std::allocator<long> >, std::vector<double, std::allocator<double> > > > > > const&)+0x195d0) [0x5571814c9f60]",
        "(OSDMonitor::prepare_command(boost::intrusive_ptr<MonOpRequest>)+0x10f) [0x5571814d044f]",
        "(OSDMonitor::prepare_update(boost::intrusive_ptr<MonOpRequest>)+0x383) [0x5571814e5983]",
        "(PaxosService::dispatch(boost::intrusive_ptr<MonOpRequest>)+0xa7d) [0x557181459c5d]",
        "(Monitor::handle_command(boost::intrusive_ptr<MonOpRequest>)+0x27ac) [0x55718131fecc]",
        "(Monitor::dispatch_op(boost::intrusive_ptr<MonOpRequest>)+0xb22) [0x557181324e32]",
        "(Monitor::_ms_dispatch(Message*)+0x457) [0x5571813260c7]",
        "(Monitor::handle_forward(boost::intrusive_ptr<MonOpRequest>)+0x8e4) [0x5571813276b4]",
        "(Monitor::dispatch_op(boost::intrusive_ptr<MonOpRequest>)+0x115d) [0x55718132546d]",
        "(Monitor::_ms_dispatch(Message*)+0x457) [0x5571813260c7]",
        "(Dispatcher::ms_dispatch2(boost::intrusive_ptr<Message> const&)+0x5c) [0x55718135688c]",
        "(DispatchQueue::entry()+0x14fa) [0x7f0ab3adf43a]",
        "(DispatchQueue::DispatchThread::entry()+0x11) [0x7f0ab3b96581]",
        "/lib64/libpthread.so.0(+0x81ca) [0x7f0ab17e01ca]",
        "clone()" 
    ],
    "ceph_version": "17.2.1",
    "crash_id": "2022-07-08T00:18:18.826414Z_71772c83-abb2-4686-8a54-acf04373a8cf",
    "entity_name": "mon.4fe0eeb4d1a92ea831e9e79b410d33b228f6cd3f",
    "os_id": "centos",
    "os_name": "CentOS Stream",
    "os_version": "8",
    "os_version_id": "8",
    "process_name": "ceph-mon",
    "stack_sig": "2a49c9b59b3e73eb6df3eba6255b5f987b3b2a5263919468c35e65a5fe30eed6",
    "timestamp": "2022-07-08T00:18:18.826414Z",
    "utsname_machine": "x86_64",
    "utsname_release": "5.10.0-14-amd64",
    "utsname_sysname": "Linux",
    "utsname_version": "#1 SMP Debian 5.10.113-1 (2022-04-29)" 
}


Related issues

Related to RADOS - Bug #59813: crash: void PaxosService::propose_pending(): assert(have_pending) Fix Under Review
Duplicates RADOS - Bug #56850: crash: void PaxosService::propose_pending(): assert(have_pending) Resolved

History

#1 Updated by Telemetry Bot over 1 year ago

  • Crash signature (v1) updated (diff)
  • Crash signature (v2) updated (diff)
  • Affected Versions v17.2.1 added

#2 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Duplicate

#3 Updated by Yaarit Hatuka 10 months ago

  • Duplicates Bug #56850: crash: void PaxosService::propose_pending(): assert(have_pending) added

#4 Updated by Yaarit Hatuka 10 months ago

Since this issue is marked as "Duplicate" it needs to specify what issue it duplicates in the "Related Issues" field.

#5 Updated by Telemetry Bot 10 months ago

  • Related to Bug #59813: crash: void PaxosService::propose_pending(): assert(have_pending) added

Also available in: Atom PDF