Project

General

Profile

Bug #56537

cephfs-top: wrong/infinitely changing wsp values

Added by Jos Collin 5 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Tags:
backport_processed
Backport:
pacific,quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs-top
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

wsp(MB/s) field in cephfs-top shows wrong and negative values changing infinitely.

Steps to reproduce:
1. Create two filesystems and mount them as client1 and client2.
2. run cephfs-top.
3. Write something to client1 only.
4. Both client1 and client2 shows changing wsp values, even if there is no IO in client2.

client1 shows changing positive values and client2 shows changing negative values. This continues infinitely since the write starts and doesn't stop when the write ends. However, this issue is not observed in 'perf stats' output.


Related issues

Copied to CephFS - Backport #57155: pacific: cephfs-top: wrong/infinitely changing wsp values Resolved
Copied to CephFS - Backport #57156: quincy: cephfs-top: wrong/infinitely changing wsp values Resolved

History

#1 Updated by Venky Shankar 5 months ago

Jos Collin wrote:

wsp(MB/s) field in cephfs-top shows wrong values when there is an IO.

Steps to reproduce:
1. Create two filesystems and mount them as client1 and client2.

userland or kclient?

2. run cephfs-top.
3. Write something to client1 only.
4. Both client1 and client2 shows changing wsp values, even if there is no IO in client2.

There can be little variance, but not huge if there is no IO.

client1 shows changing positive values and client2 shows changing negative values. This continues infinitely since the write starts and doesn't stop when the write ends.
However, this issue is not observed in 'perf stats' output.

So, I think this is a bug in fstop and not in client/mds?

#2 Updated by Jos Collin 5 months ago

Venky Shankar wrote:

Jos Collin wrote:

wsp(MB/s) field in cephfs-top shows wrong values when there is an IO.

Steps to reproduce:
1. Create two filesystems and mount them as client1 and client2.

userland or kclient?

both

2. run cephfs-top.
3. Write something to client1 only.
4. Both client1 and client2 shows changing wsp values, even if there is no IO in client2.

There can be little variance, but not huge if there is no IO.

As I understand, wsp(MB/s) should come to 0 when the IO ends? But it never comes to 0. The client2 goes negative too. This happens probably because the `size` variable used to calculate the wsp value doesn't reset when there's a new client.

client1 shows changing positive values and client2 shows changing negative values. This continues infinitely since the write starts and doesn't stop when the write ends.
However, this issue is not observed in 'perf stats' output.

So, I think this is a bug in fstop and not in client/mds?

Yes, it's a bug in cephfs-top.

#3 Updated by Jos Collin 5 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 47099

#4 Updated by Venky Shankar 3 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Target version set to v18.0.0
  • Backport set to pacific,quincy

#5 Updated by Backport Bot 3 months ago

  • Copied to Backport #57155: pacific: cephfs-top: wrong/infinitely changing wsp values added

#6 Updated by Backport Bot 3 months ago

  • Copied to Backport #57156: quincy: cephfs-top: wrong/infinitely changing wsp values added

#7 Updated by Backport Bot 3 months ago

  • Tags set to backport_processed

#8 Updated by Jos Collin 3 months ago

  • Description updated (diff)

#9 Updated by Jos Collin 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF