Project

General

Profile

Bug #565

Example config file is broken

Added by Ravi Pinjala almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
OSD
Target version:
Start date:
11/08/2010
Due date:
% Done:

0%

Estimated time:
0.50 h
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The example config file (src/sample.ceph.conf) specifies the OSD journal as a file, but doesn't specify the size, which is a required option if the journal is a file and not a block device. Because of this, a cluster built starting from the example config doesn't work. Ceph says nothing about this except in the logs, so it's difficult for a new user to even know why their new cluster isn't working.

History

#1 Updated by Sage Weil almost 9 years ago

  • Category set to OSD
  • Assignee set to Colin McCabe
  • Priority changed from Normal to Immediate
  • Target version set to v0.23
  • Estimated time set to 0.50 h
  • Source changed from 0 to 1

#2 Updated by Colin McCabe almost 9 years ago

  • Status changed from New to Resolved

Fixed by 2325a1a27b434cea7d7af832efff7a9257724fe6

C.

Also available in: Atom PDF