Project

General

Profile

Bug #56483

mgr/stats: missing clients in perf stats command output.

Added by Neeraj Pratap Singh 5 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Tags:
backport_processed
Backport:
quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs-top
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

perf stats doesn't get the client info w.r.t filesystems created after running the perf stats command once with existing filesystems.

Steps to reproduce:
1. Run vstart without any filesystem.
2. Run `./bin/ceph mgr module enable stats` and then run `watch ./bin/ceph fs perf stats` in another terminal.
3. Create a filesystem fs1 --> `./bin/ceph fs volume create fs1` and mount it
4. Check the perf stats output(watch), we will get to see the data/clients related to fs1
5. Create another filesystem fs2 --> `./bin/ceph fs volume create fs2` and mount it
6. Check the perf stats output(watch), we won't see the new fs2 related data/clients.


Related issues

Copied to CephFS - Backport #57273: quincy: mgr/stats: missing clients in perf stats command output. Resolved
Copied to CephFS - Backport #57274: pacific: mgr/stats: missing clients in perf stats command output. Resolved

History

#1 Updated by Jos Collin 5 months ago

  • Description updated (diff)

#2 Updated by Neeraj Pratap Singh 5 months ago

  • Description updated (diff)
  • Category set to Correctness/Safety
  • Status changed from New to In Progress
  • Assignee set to Neeraj Pratap Singh

#3 Updated by Venky Shankar 5 months ago

Neeraj, does this fix require backport to q/p or is it due to a recently pushed change?

#4 Updated by Neeraj Pratap Singh 5 months ago

Venky Shankar wrote:

Neeraj, does this fix require backport to q/p or is it due to a recently pushed change?

It arose due to this fix https://github.com/ceph/ceph/commit/c0c05efaf32471dce7138a43de5fee82678d51c9 .If it was backported, then this also needs to be backported.

#5 Updated by Neeraj Pratap Singh 5 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 47079

#6 Updated by Venky Shankar 5 months ago

  • Backport set to quincy, pacific
  • Component(FS) cephfs-top added

#7 Updated by Venky Shankar 4 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Target version set to v18.0.0

#8 Updated by Backport Bot 4 months ago

  • Copied to Backport #57273: quincy: mgr/stats: missing clients in perf stats command output. added

#9 Updated by Backport Bot 4 months ago

  • Copied to Backport #57274: pacific: mgr/stats: missing clients in perf stats command output. added

#10 Updated by Backport Bot 4 months ago

  • Tags set to backport_processed

#11 Updated by Neeraj Pratap Singh about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF